summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Osman2018-11-15 23:47:47 -0800
committerNathan Osman2018-11-15 23:47:47 -0800
commita8781d0edb8765b45106e9645480f525327ba1ac (patch)
tree9618c69264669380a70d94a3c18c3f22f5b44e0c
parent2e6c62babdde8bb7ae84230817cb4c7c6d7e09a5 (diff)
downloadaur-a8781d0edb8765b45106e9645480f525327ba1ac.tar.gz
Update to apply patch for building against Qt 5.11.
-rw-r--r--PKGBUILD11
-rw-r--r--qt-5.11.patch14
2 files changed, 23 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7998d4ce2f2d..b8b05b00129b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='nitroshare'
pkgver='0.3.4'
-pkgrel=1
+pkgrel=2
pkgdesc='Network File Transfer Application'
url='https://nitroshare.net'
arch=('i686' 'x86_64')
@@ -18,8 +18,15 @@ optdepends=(
)
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/nitroshare/nitroshare-desktop/archive/$pkgver.tar.gz"
+ "qt-5.11.patch"
)
-sha256sums=('29874e5909c29211a3c9e13f8c0f49b901ec2996e5d60d80af80d2fb80c3d7ec')
+sha256sums=('29874e5909c29211a3c9e13f8c0f49b901ec2996e5d60d80af80d2fb80c3d7ec'
+ 'e2a8417f36a5df37c5fb34c1a371f86b0059f48bf6dd588fc776ca7c38a67cd5')
+
+prepare() {
+ cd "$pkgname-desktop-$pkgver"
+ patch -Np1 -i ../qt-5.11.patch
+}
build() {
cd "$pkgname-desktop-$pkgver"
diff --git a/qt-5.11.patch b/qt-5.11.patch
new file mode 100644
index 000000000000..b716deca6707
--- /dev/null
+++ b/qt-5.11.patch
@@ -0,0 +1,14 @@
+diff -Nru a/src/application/splashdialog.cpp
+b/src/application/splashdialog.cpp
+--- a/src/application/splashdialog.cpp 2017-10-13 00:32:54.000000000
++0200
++++ b/src/application/splashdialog.cpp 2018-06-01 03:45:40.631194527
++0200
+@@ -24,6 +24,7 @@
+
+ #include <QApplication>
+ #include <QDesktopWidget>
++#include <QStyle>
+
+ #include "splashdialog.h"
+