summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcan1s2015-06-08 19:56:45 +0300
committerarcan1s2015-06-08 19:56:45 +0300
commitc6b356e787a6a154c8a1346ae0475ac1380277e1 (patch)
tree74cb30fb054b80b2a2f81ddcb7c0c065cc04bd8f
downloadaur-c6b356e787a6a154c8a1346ae0475ac1380277e1.tar.gz
upload nitrux-icon-theme
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09121b3d55b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nitrux-icon-theme
+ pkgdesc = New squared icon set for Linux that sports clean lines, smooth gradients, and simple icon logos
+ pkgver = 3.5.1
+ pkgrel = 1
+ url = http://nitrux.in/store/nitrux-icon-theme/
+ arch = any
+ license = custom:Creative Commons
+ depends = librsvg
+ options = !strip
+ source = http://nitrux.in/downloads/files/free/nitrux-icon-theme-3.5.1.tar.gz
+ md5sums = 538d07a0cf198ffb708251572450d856
+
+pkgname = nitrux-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e02cd84cacce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: msimav <mustafa1991 at gmail dot com>
+
+pkgname=nitrux-icon-theme
+pkgver=3.5.1
+pkgrel=1
+pkgdesc="New squared icon set for Linux that sports clean lines, smooth gradients, and simple icon logos"
+url="http://nitrux.in/store/nitrux-icon-theme/"
+arch=('any')
+license=('custom:Creative Commons')
+source=("http://nitrux.in/downloads/files/free/${pkgname}-${pkgver}.tar.gz")
+depends=('librsvg')
+options=(!strip)
+md5sums=('538d07a0cf198ffb708251572450d856')
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/icons"
+ cp -r "${srcdir}/Nitrux" "${pkgdir}/usr/share/icons/${pkgname}"
+ find "${pkgdir}/usr/share/icons" -type d -exec chmod 755 '{}' \;
+ find "${pkgdir}/usr/share/icons" -type f -exec chmod 644 '{}' \;
+
+ install -Dm644 "${pkgdir}/usr/share/"{icons,licenses}"/${pkgname}/COPYING"
+}