summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcan1s2015-06-08 19:56:48 +0300
committerarcan1s2015-06-08 19:56:48 +0300
commit61bc74da6bdb7fa7e68f0048e42edd60afe02653 (patch)
tree72e142d175c66a856828a9a9694c65876c1f9d98
downloadaur-61bc74da6bdb7fa7e68f0048e42edd60afe02653.tar.gz
upload nitrux-icon-theme-kde
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d844cd965218
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nitrux-icon-theme-kde
+ pkgdesc = The KDE version of the Nitrux OS Icons
+ pkgver = 3.5.1
+ pkgrel = 1
+ url = http://nitrux.in/store/nitrux-for-kde/
+ arch = any
+ license = Creative Commons
+ depends = librsvg
+ options = !strip
+ source = http://nitrux.in/downloads/files/free/nitrux-icon-theme-kde-3.5.1.tar.gz
+ md5sums = 21d000e0f760e8e01cfa9ac3fef14f0f
+
+pkgname = nitrux-icon-theme-kde
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32db3c0d93b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: localizator <localizator at ukr dot net>
+
+pkgname=nitrux-icon-theme-kde
+pkgver=3.5.1
+pkgrel=1
+pkgdesc="The KDE version of the Nitrux OS Icons"
+url="http://nitrux.in/store/nitrux-for-kde/"
+arch=('any')
+license=('Creative Commons')
+source=("http://nitrux.in/downloads/files/free/${pkgname}-${pkgver}.tar.gz")
+depends=('librsvg')
+options=(!strip)
+md5sums=('21d000e0f760e8e01cfa9ac3fef14f0f')
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/icons"
+ cp -r "${srcdir}/Nitrux" "${pkgdir}/usr/share/icons/${pkgname}"
+ find "${pkgdir}/usr/share/icons" -type d -exec chmod 755 '{}' \;
+ find "${pkgdir}/usr/share/icons" -type f -exec chmod 644 '{}' \;
+
+ install -Dm644 "${pkgdir}/usr/share/"{icons,licenses}"/${pkgname}/COPYING"
+}