summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomini2021-12-31 01:21:08 +0000
committersomini2021-12-31 01:21:08 +0000
commit45ab20b033798f0d7c2c2bbd8ae6019ce7f6e6dd (patch)
treeabf5f1a644ee410929e94bc1d1bc2af2f9bad7fe
parent2dafbb3814117d8ab8d119f07c47470b775550a6 (diff)
downloadaur-45ab20b033798f0d7c2c2bbd8ae6019ce7f6e6dd.tar.gz
Update patch to comply with the latest changes
See: - https://github.com/zedeus/nitter/commit/9eb7532bfa1388c9ea72fc3dcc7e67d615e83222 Thanks, @nyanpasu64
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--config.patch20
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8da1b678cb96..eb30119478b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nitter-git
pkgdesc = Alternative Twitter front-end
pkgver = latest
- pkgrel = 13
+ pkgrel = 14
url = https://github.com/zedeus/nitter
install = nitter.install
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = nitter-git
source = nitter.service
source = nitter.install
sha256sums = SKIP
- sha256sums = f88c21177ec3a6f44c248b5b16cdf9a446d3945292996a266407e5da8530501d
+ sha256sums = cb5d8f36066389c15da92f4774233e59a18c4d4c3781e273941656c651c1cf91
sha256sums = 620e38c7bb978a64d276b499d097ec4967fe8bda16852fe0c416ed61744b6526
sha256sums = 79469c5cfeacf38c7469a2240ba5c19670ddaf757e6d1b5286206a18a0718487
sha256sums = 560d98833c56979cb6b5d187a827788dbbdff95871f957225604b58b15c1c219
diff --git a/PKGBUILD b/PKGBUILD
index ee666c07bb63..04db59d6f3cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=nitter
pkgname=nitter-git
pkgver=latest
-pkgrel=13
+pkgrel=14
pkgdesc="Alternative Twitter front-end"
url="https://github.com/zedeus/nitter"
depends=('redis')
@@ -20,7 +20,7 @@ source=("$pkgname::git+$url.git#branch=master"
"nitter.service"
"nitter.install")
sha256sums=('SKIP'
- 'f88c21177ec3a6f44c248b5b16cdf9a446d3945292996a266407e5da8530501d'
+ 'cb5d8f36066389c15da92f4774233e59a18c4d4c3781e273941656c651c1cf91'
'620e38c7bb978a64d276b499d097ec4967fe8bda16852fe0c416ed61744b6526'
'79469c5cfeacf38c7469a2240ba5c19670ddaf757e6d1b5286206a18a0718487'
'560d98833c56979cb6b5d187a827788dbbdff95871f957225604b58b15c1c219'
@@ -37,6 +37,8 @@ pkgver() {
prepare() {
cd "$pkgname"
+ # Move example config file to the final location
+ mv -v nitter.example.conf nitter.conf
# Tweak the configuration file
patch -p1 <"$srcdir/config.patch"
}
diff --git a/config.patch b/config.patch
index bddd4b916be4..bc36f02f3a04 100644
--- a/config.patch
+++ b/config.patch
@@ -1,7 +1,7 @@
-diff --git i/nitter.conf w/nitter.conf
-index d6d860b..877b270 100644
---- i/nitter.conf
-+++ w/nitter.conf
+diff --git a/nitter.conf b/nitter.conf
+index 93526b4..c11e819 100644
+--- a/nitter.conf
++++ b/nitter.conf
@@ -1,11 +1,11 @@
[Server]
-address = "0.0.0.0"
@@ -19,7 +19,7 @@ index d6d860b..877b270 100644
[Cache]
listMinutes = 240 # how long to cache list info (not the tweets, so keep it high)
-@@ -19,8 +17,8 @@ redisMaxConnections = 30
+@@ -20,8 +20,8 @@ redisMaxConnections = 30
# you receive tons of requests per second
[Config]
@@ -27,19 +27,21 @@ index d6d860b..877b270 100644
-base64Media = false # use base64 encoding for proxied media urls
+hmacKey = "43179cf305cda132874f7a4d3fa4831a01528e516780157bebd564b0ca0297c2" # Regenerate e.g. `head -c 25 </dev/urandom | sha256sum`
+base64Media = true # use base64 encoding for proxied media urls
- tokenCount = 10
- # minimum amount of usable tokens. tokens are used to authorize API requests,
- # but they expire after ~1 hour, and have a limit of 187 requests.
-@@ -30,9 +28,9 @@ tokenCount = 10
+ enableRSS = true # set this to false to disable RSS feeds
+ proxy = "" # proxy type http/https
+ proxyAuth = ""
+@@ -34,10 +34,10 @@ tokenCount = 10
# Change default preferences here, see src/prefs_impl.nim for a complete list
[Preferences]
-theme = "Nitter"
-replaceTwitter = "nitter.net"
-replaceYouTube = "piped.kavin.rocks"
+-replaceReddit = "teddit.net"
+theme = "twitter_dark" # Change this?
+replaceTwitter = "nitter.net" # Use the same "hostname" as above
+replaceYouTube = "" # Default: piped.kavin.rocks
++replaceReddit = "" # Default: teddit.net
replaceInstagram = ""
proxyVideos = true
hlsPlayback = false