summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomini2020-07-12 15:46:15 +0100
committersomini2020-07-12 15:46:15 +0100
commitc789e384afaf14593e4c70c392ca3ea543dd0422 (patch)
treef2cc450b3bc8c6e281c7530ef83b22611d6e1069
parent9e34e8b725912e49da998867ea12247be9505e0f (diff)
downloadaur-c789e384afaf14593e4c70c392ca3ea543dd0422.tar.gz
Tweak the patching code
This should fix finding the patch file on chroot builds.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b33cab8cbb8..8725a2d0c8cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nitter-git
pkgdesc = Alternative Twitter front-end
pkgver = latest
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/zedeus/nitter
install = nitter.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9f95cedf7ac0..e2e4cd8d9913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=nitter
pkgname=nitter-git
pkgver=latest
-pkgrel=6
+pkgrel=7
pkgdesc="Alternative Twitter front-end"
url="https://github.com/zedeus/nitter"
depends=('redis')
@@ -34,12 +34,16 @@ pkgver() {
)
}
+prepare() {
+ cd "$pkgname"
+
+ # Tweak the configuration file
+ patch -p1 <"$srcdir/config.patch"
+}
+
build() {
cd "${srcdir}/$pkgname"
- # Tweak the configuration file
- patch -p1 <../../config.patch
-
# Based on the Dockerfile
nimble build -y -d:release
strip -s nitter