summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorproninyaroslav2015-07-12 18:33:22 +0300
committerproninyaroslav2015-07-12 18:33:22 +0300
commit7115c33f047295e6e9a0c107e73bb656dbee8494 (patch)
tree5a895176464232567eb4545dedb2b6fcefe82557
downloadaur-7115c33f047295e6e9a0c107e73bb656dbee8494.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1de4be037602
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nixnote
+ pkgdesc = Formerly called nevernote, nixnote is a clone of Evernote designed to run on Linux.
+ pkgver = 1.6
+ pkgrel = 1
+ url = http://www.sourceforge.net/projects/nevernote/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = java-runtime
+ depends = libpng12
+ source = http://sourceforge.net/projects/nevernote/files/NixNote%201.6/nixnote-1.6_amd64.tar.gz/download
+
+pkgname = nixnote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab64d407dfa1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: yaroslav <proninyaroslav@mail.ru>
+# Contributor: Chris Fordham <chris at fordham-nagy dot id dot au> aka flaccid
+# Contributor: J. Luck <jluck@udel.edu>
+# Package Build Source: https://github.com/flaccid/archlinux-packages/blob/master/nixnote/PKGBUILD
+
+pkgname=nixnote
+pkgver=1.6
+_pkgver='NixNote%201.6'
+pkgrel=1
+pkgdesc="Formerly called nevernote, nixnote is a clone of Evernote designed to run on Linux."
+url="http://www.sourceforge.net/projects/nevernote/"
+arch=('x86_64' 'i686')
+_arch='amd64'
+license=('GPL')
+depends=(
+ 'java-runtime'
+ 'libpng12'
+)
+sha256sum=('781f8b9cbe3e1137b62d4dbb76670b3e2d5a20403b04b3767e03a2e89dba860e')
+
+if [ "$CARCH" = 'i686' ]; then
+ _arch=i386
+ sha256sum=('50be711e33d37fd43590845718e5e5710cc48a5f7f745df8990b0f792da3a7da')
+fi;
+
+source="http://sourceforge.net/projects/nevernote/files/${_pkgver}/${pkgname}-${pkgver}_${_arch}.tar.gz/download"
+
+package()
+{
+ cp -R "$srcdir/nixnote/usr" "$pkgdir/"
+ mv "$pkgdir/usr/bin/nixnote.sh" "$pkgdir/usr/bin/nixnote"
+}
+
+# vim:set ts= 2 sw=2 Et:
+