summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormortz2017-02-18 16:09:22 +0330
committermortz2017-02-18 16:09:22 +0330
commit1890d6f9d34feddb0bb08c121e026ea1c567dca4 (patch)
tree2c93f01ea15fd0bcee6055ae4276328c5c87bc85
parenta646390419af9f8d078db0aa906c3d397c724868 (diff)
downloadaur-1890d6f9d34feddb0bb08c121e026ea1c567dca4.tar.gz
Fix libcurl
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--nixnote2.sh3
3 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f966f49658a8..a7eff9b8172d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nixnote2
pkgdesc = Formerly called nevernote, nixnote is a clone of Evernote designed to run on Linux
pkgver = 2.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.sourceforge.net/projects/nevernote
arch = x86_64
arch = i686
@@ -21,7 +21,9 @@ pkgbase = nixnote2
conflicts = nixnote-beta
replaces = nixnote
source = nixnote2.desktop
- sha256sums = 6c88cd5ae3f5c18e342fcf5165891b22d99818d3fe2ac2b124262b8ba23bb4d1
+ source = nixnote2.sh
+ sha256sums = 227e6b13fce129adb492b1ab4b94eb3b56777a5939d02ae606b07f217bdb6182
+ sha256sums = 2622af966b844ad7fdfc282a5a8bcff1eb44269a148b2f5759fa8f1de8188370
source_x86_64 = https://superb-sea2.dl.sourceforge.net/project/nevernote/NixNote2%20-%202.0/Linux/Qt5/nixnote2-2.0_amd64.tar.gz
sha256sums_x86_64 = 932055ac4e47e205b95642c19000e7c8fe06e688e536fa9d1ec49ecdaf86eab4
source_i686 = https://superb-sea2.dl.sourceforge.net/project/nevernote/NixNote2%20-%202.0/Linux/Qt5/nixnote2-2.0_i386.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 2a44d01a639e..3e29965c76bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=nixnote2
_pkgname=nixnote2
pkgver=2.0
_pkgver="NixNote2%20-%202.0"
-pkgrel=1
+pkgrel=2
pkgdesc="Formerly called nevernote, nixnote is a clone of Evernote designed to run on Linux"
url="http://www.sourceforge.net/projects/nevernote"
arch=('x86_64' 'i686')
@@ -12,10 +12,10 @@ license=('GPL2')
provides=('nixnote2')
conflicts=('nixnote' 'nixnote2-git' 'nixnote-beta')
replaces=('nixnote')
-source=("nixnote2.desktop")
+source=("nixnote2.desktop" "nixnote2.sh")
depends=('mimetex' 'opencv' 'poppler-qt5' 'qt5-base' 'qt5-webkit' 'sqlite' 'tidyhtml' 'qtwebkit' 'libcurl-compat')
-sha256sums=('227e6b13fce129adb492b1ab4b94eb3b56777a5939d02ae606b07f217bdb6182')
+sha256sums=('227e6b13fce129adb492b1ab4b94eb3b56777a5939d02ae606b07f217bdb6182' '2622af966b844ad7fdfc282a5a8bcff1eb44269a148b2f5759fa8f1de8188370')
source_x86_64=("https://superb-sea2.dl.sourceforge.net/project/nevernote/${_pkgver}/Linux/Qt5/${_pkgname}-2.0_amd64.tar.gz")
sha256sums_x86_64=('932055ac4e47e205b95642c19000e7c8fe06e688e536fa9d1ec49ecdaf86eab4')
source_i686=("https://superb-sea2.dl.sourceforge.net/project/nevernote/${_pkgver}/Linux/Qt5/${_pkgname}-2.0_i386.tar.gz")
@@ -24,4 +24,6 @@ sha256sums_i686=('9a829cd33ad7fbd6f1e83a0b3182aa3e6be2c56a9f5dbd6ed32cc320b0f9ce
package() {
cp -R "${srcdir}/nixnote2/usr" "${pkgdir}/"
install -D -m644 nixnote2.desktop ${pkgdir}/usr/share/applications/nixnote2.desktop
+ sudo cp nixnote2.sh /usr/local/bin/nixnote2
+ sudo chmod +x /usr/local/bin/nixnote2
}
diff --git a/nixnote2.sh b/nixnote2.sh
new file mode 100644
index 000000000000..59bfaa5f48b4
--- /dev/null
+++ b/nixnote2.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+env "LD_PRELOAD=libcurl.so.3" /usr/bin/nixnote2