summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom "Ravi" Hale2023-06-27 17:53:18 +0700
committerTom "Ravi" Hale2023-06-29 09:40:08 +0700
commit7f4ddc5c90943f2a5ddb5d97be4614d8308497d8 (patch)
tree2cbb141aae08bcb1fb8dfc77dba0dfbf79b18d3c
parent9c280ae92c052a27afaf5bd5b3ceaf0ab601ed78 (diff)
downloadaur-7f4ddc5c90943f2a5ddb5d97be4614d8308497d8.tar.gz
Get AppImage via source array
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d14ed10f35c9..0900effcdd04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,16 +15,11 @@ makedepends=(git)
conflicts=(nixnote2-git)
provides=("nixnote=${pkgver%.r*}" "$_pkgname=${pkgver%.r*}")
replaces=(nevernote nixnote nixnote-beta)
-source=("$pkgname:desktop.patch")
-noextract=("${source[@]%%::*}") # Don't extract anything
+_appimage=NixNote2-x86_64.AppImage
+source=('https://github.com/robert7/nixnote2/releases/download/continuous/'"$_appimage")
+b2sums=(SKIP) # Source will change as new versions are released
+noextract=("${source[@]%%::*}") # Don't auto-extract anything
-_version_file=$pkgname-PKGBUILD-version # For version from the download URL
-
-_appimage_path=$(curl -s 'https://github.com/robert7/nixnote2/releases' |
- sed -En 's:.*(/releases/download/v[^"/]+/[^"/]+[Aa]pp[Ii]mage)".*:\1:p' |
- head -n1)
-
-_appimage=${_appimage_path##*/} # basename of AppImage
prepare() {
wget -N "$url/$_appimage_path" # Only download again if server version is newer