summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom "Ravi" Hale2018-10-13 18:10:53 +0700
committerTom "Ravi" Hale2023-06-29 09:40:08 +0700
commitbab3f8e2877e7c58f3a5f7cddcb925529ed8397b (patch)
tree3b43bbd251d1746a7d962eab8ff69fa61600a323
parentfefb5496afa93d615ae1af11b819dd940f7fd49b (diff)
downloadaur-bab3f8e2877e7c58f3a5f7cddcb925529ed8397b.tar.gz
Add make-check and srcinfo-update
-rwxr-xr-xmake-check21
-rwxr-xr-xsrcinfo-update9
2 files changed, 30 insertions, 0 deletions
diff --git a/make-check b/make-check
new file mode 100755
index 000000000000..d21afdb28ff7
--- /dev/null
+++ b/make-check
@@ -0,0 +1,21 @@
+#!/bin/bash
+
+# A convenience script for the package creator.
+# This file is not run on package installation.
+
+PACMAN=
+PATH=/usr/bin:$PATH
+
+pkgdir=${0%%/*} # dirname $0
+cd -P -- "$pkgdir" || exit 1 # Allow to be called from any directory
+
+if [[ -d src ]]; then
+ makepkg -ef
+else
+ makepkg -f
+fi
+
+namcap PKGBUILD
+namcap ./*.tar.xz
+
+makepkg --printsrcinfo >| .SRCINFO && echo "Updated .SRCINFO" >&2
diff --git a/srcinfo-update b/srcinfo-update
new file mode 100755
index 000000000000..b99adca92db9
--- /dev/null
+++ b/srcinfo-update
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+# A convenience script for the package creator.
+# This file is not run on package installation.
+
+pkgdir=${0%%/*} # dirname $0
+cd -P -- "$pkgdir" || exit 1 # Allow to be called from any directory
+
+makepkg --printsrcinfo >| .SRCINFO && echo "Updated .SRCINFO" >&2