summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom "Ravi" Hale2018-10-05 12:42:13 +0700
committerTom "Ravi" Hale2018-10-07 17:32:37 +0700
commit1a9c62a3d9d7f317ed3e0d86aefdcbd3e53bfba4 (patch)
treed0c58415806c004cf71a72b398fc22e0759212a8
parentd6fd90b4caa5bbb02fc18c45dc6e16d646ac492f (diff)
downloadaur-1a9c62a3d9d7f317ed3e0d86aefdcbd3e53bfba4.tar.gz
Update to github.com/robert7/nixnote2
-rw-r--r--PKGBUILD67
-rw-r--r--README1
2 files changed, 26 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c79d75c186e2..3a9c6b92aede 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,40 @@
-# Maintainer: twa022 <twa022 at gmail dot com>
+# Maintainer: Tom Hale <tom[noodle]hale[point]ee>
+# Contributor: twa022 <twa022 at gmail dot com>
_pkgname=nixnote2
+_repo_url="https://github.com/robert7/${_pkgname}.git"
pkgname=${_pkgname}-git
-pkgver=2.0.r100.g82865e0
+pkgver=2.1.0.beta3.r95.g8f235769
pkgrel=1
-pkgdesc="Evernote clone (formerly Nevernote) -- git checkout"
-url="http://www.nixnote.org"
-arch=('x86_64' 'i686')
-license=('GPL2')
-conflicts=("${_pkgname/2/}" "${_pkgname/2/}-beta" "${_pkgname}")
-provides=("${_pkgname}=${pkgver%.r*}" "${_pkgname/2/}=${pkgver%.r*}")
-replaces=('nevernote')
-depends=('poppler-qt5' 'qt5-webkit' 'boost-libs')
-makedepends=('git' 'boost' 'opencv' 'hunspell')
-optdepends=('opencv: Webcam plugin'
- 'hunspell: Spell check plugin')
-source=("${_pkgname}"::git+https://github.com/baumgarr/nixnote2)
+pkgdesc="Evernote clone (formerly Nevernote) - git checkout"
+url="https://github.com/robert7/nixnote2"
+arch=(x86_64)
+license=('GPL3')
+depends=(java-runtime hicolor-icon-theme poppler-qt5 tidy qt5-webkit)
+makedepends=(git)
+provides=("nixnote=${pkgver%.r*}" "$_pkgname=${pkgver%.r*}")
+replaces=(nevernote nixnote nixnote-beta)
+source=("${_pkgname}"::git+$_repo_url)
sha256sums=('SKIP')
+set -o pipefail
+
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed -r "s/^v//;s/([^-]*-g)/r\1/;s/-/./g"
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_pkgname}"
-
- qmake PREFIX=/usr ./NixNote2.pro
- make
-
- # Build the plugins
- cd plugins/hunspell
- qmake Hunspell.pro
- make
- cd -
-
- cd plugins/webcam
- qmake WebCam.pro
+ cd "$srcdir/$_pkgname"
+ qmake PREFIX=/usr
make
+ # Strip the binary to save 160MB of disk in src tree
+ strip qmake-build-release/"$_pkgname"
}
package() {
- cd "${srcdir}/${_pkgname}"
- make INSTALL_ROOT="${pkgdir}" install
-
- mkdir -p "${pkgdir}"/usr/lib/nixnote2/plugins
- install -m755 plugins/*so "${pkgdir}"/usr/lib/nixnote2/plugins/
- # Binaries should really be in lib, not share
- ln -s '../..'/lib/nixnote2/plugins "${pkgdir}"/usr/share/nixnote2/plugins
-
- install -m644 theme.ini "${pkgdir}"/usr/share/nixnote2/theme.ini
-
- sed -i 's:nevernote:nixnote:g' shortcuts_howto.txt
- install -Dm644 shortcuts_howto.txt "${pkgdir}"/usr/doc/nixnote2/shortcuts_howto.txt
- install -Dm644 shortcuts.txt "${pkgdir}"/usr/doc/nixnote2/shortcuts_sample.txt
+ cd "$_pkgname"
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 shortcuts.txt "${pkgdir}/usr/share/doc/${_pkgname}/shortcuts_sample.txt"
+ install -Dm644 docs/{shortcuts-howto,CHANGELOG}.md "${pkgdir}/usr/share/doc/${_pkgname}"
}
diff --git a/README b/README
new file mode 100644
index 000000000000..1c91eeb92b0e
--- /dev/null
+++ b/README
@@ -0,0 +1 @@
+https://aur.archlinux.org/packages/nixnote2-git/