summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom "Ravi" Hale2018-10-08 09:20:08 +0700
committerTom "Ravi" Hale2018-10-08 09:28:12 +0700
commit1e4194dc8e6e69704775fcc61deb3947a112ac64 (patch)
tree679e1617eba02c9ea47a848a0528d01b1cf762bc
parent5c4ab948b3f600306803acc0c85204cfae1b66ac (diff)
downloadaur-1e4194dc8e6e69704775fcc61deb3947a112ac64.tar.gz
Remove strip from build()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24b3557a89ca..6ce0109a19a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nixnote2-git
pkgdesc = Evernote clone (formerly Nevernote) - git checkout
pkgver = 2.1.0.beta3.r95.g8f235769
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/robert7/nixnote2
arch = x86_64
license = GPL3
@@ -16,7 +16,7 @@ pkgbase = nixnote2-git
replaces = nevernote
replaces = nixnote
replaces = nixnote-beta
- source = nixnote2::git+https://github.com/robert7/nixnote2.git
+ source = git+https://github.com/robert7/nixnote2.git
sha256sums = SKIP
pkgname = nixnote2-git
diff --git a/PKGBUILD b/PKGBUILD
index 3a9c6b92aede..f5fbcabdab90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,20 @@
# Contributor: twa022 <twa022 at gmail dot com>
_pkgname=nixnote2
-_repo_url="https://github.com/robert7/${_pkgname}.git"
pkgname=${_pkgname}-git
pkgver=2.1.0.beta3.r95.g8f235769
-pkgrel=1
-pkgdesc="Evernote clone (formerly Nevernote) - git checkout"
-url="https://github.com/robert7/nixnote2"
+pkgrel=2
+pkgdesc='Evernote clone (formerly Nevernote) - git checkout'
+url="https://github.com/robert7/$_pkgname"
arch=(x86_64)
-license=('GPL3')
+license=(GPL3)
depends=(java-runtime hicolor-icon-theme poppler-qt5 tidy qt5-webkit)
makedepends=(git)
provides=("nixnote=${pkgver%.r*}" "$_pkgname=${pkgver%.r*}")
replaces=(nevernote nixnote nixnote-beta)
-source=("${_pkgname}"::git+$_repo_url)
+source=("git+${url}.git")
sha256sums=('SKIP')
-set -o pipefail
-
pkgver() {
cd "$srcdir/$_pkgname"
git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
@@ -28,13 +25,12 @@ build() {
cd "$srcdir/$_pkgname"
qmake PREFIX=/usr
make
- # Strip the binary to save 160MB of disk in src tree
- strip qmake-build-release/"$_pkgname"
}
package() {
cd "$_pkgname"
make INSTALL_ROOT="$pkgdir" install
- install -Dm644 shortcuts.txt "${pkgdir}/usr/share/doc/${_pkgname}/shortcuts_sample.txt"
- install -Dm644 docs/{shortcuts-howto,CHANGELOG}.md "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}/" docs/{shortcuts-howto,CHANGELOG}.md
+ # Rename shortcuts.txt to align with shortcuts-howto.md:
+ install -m644 shortcuts.txt "${pkgdir}/usr/share/doc/${_pkgname}/shortcuts_sample.txt"
}