summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Faraone2011-02-05 23:13:21 -0800
committerMarkus Heidelberg2015-06-26 10:54:06 +0200
commit029e128568edff26256db5aa6fcfeb9294f60f6c (patch)
tree29c96727928c47ede0b2be998bed55bd966457f2
downloadaur-029e128568edff26256db5aa6fcfeb9294f60f6c.tar.gz
njam 1.25-6: initial import
** Manually imported from AUR 3 **
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--njam.desktop18
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c57a16781912
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = njam
+ pkgdesc = Full-featured cross-platform pacman-like game
+ pkgver = 1.25
+ pkgrel = 6
+ url = http://njam.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_net
+ source = http://downloads.sourceforge.net/njam/njam-1.25-src.tar.gz
+ source = njam.desktop
+ md5sums = b49f65a0c5df83de85df4f985337e2eb
+ md5sums = a2e8f7e419de1b864c31342003ebcd4d
+
+pkgname = njam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4158fb7a8e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Stefano "GeniE" Faraone <xgotux@gmail.com>
+
+pkgname=njam
+pkgver=1.25
+pkgrel=6
+pkgdesc="Full-featured cross-platform pacman-like game"
+url="http://njam.sourceforge.net/"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('sdl_image' 'sdl_mixer' 'sdl_net')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz njam.desktop)
+md5sums=('b49f65a0c5df83de85df4f985337e2eb' 'a2e8f7e419de1b864c31342003ebcd4d')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}-src
+ ./configure --prefix=/usr
+ make clean || return 1 # Delete the binary files which are distributed in the tar file
+ make || return 1
+ make DESTDIR=${pkgdir} install
+ install -Dm644 njamicon.ico ${pkgdir}/usr/share/pixmaps/njamicon.ico
+ install -Dm644 ${srcdir}/njam.desktop ${pkgdir}/usr/share/applications/njam.desktop
+}
diff --git a/njam.desktop b/njam.desktop
new file mode 100644
index 000000000000..a03239d4956c
--- /dev/null
+++ b/njam.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Njam
+
+Comment=Pacman Clone
+
+Type=Application
+Categories=ArcadeGame;Game;
+
+TryExec=njam
+Exec=njam
+
+Icon=/usr/share/pixmaps/njamicon.ico
+Terminal=false
+
+GenericName=Pacman Clone
+Categories=Application;Game;