summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Heidelberg2011-10-30 13:13:00 +0100
committerMarkus Heidelberg2015-06-26 10:57:16 +0200
commit212e666d1eb143e171bf1044b3bd4b91320558cf (patch)
tree2105e5710260d1546d56a3720f3f74f67168674a
parent029e128568edff26256db5aa6fcfeb9294f60f6c (diff)
downloadaur-212e666d1eb143e171bf1044b3bd4b91320558cf.tar.gz
njam 1.25-7: fix compile errors
Compile errors fixed with a patch from Gentoo. error: cannot call constructor ‘LogFile::LogFile’ directly error: for a function-style cast, remove the redundant ‘::LogFile’ ** Manually imported from AUR 3 **
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--njam-1.25-gcc45-archlinux.patch25
3 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c57a16781912..d287a62d581a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = njam
pkgdesc = Full-featured cross-platform pacman-like game
pkgver = 1.25
- pkgrel = 6
+ pkgrel = 7
url = http://njam.sourceforge.net/
arch = i686
arch = x86_64
@@ -11,8 +11,10 @@ pkgbase = njam
depends = sdl_net
source = http://downloads.sourceforge.net/njam/njam-1.25-src.tar.gz
source = njam.desktop
+ source = njam-1.25-gcc45-archlinux.patch
md5sums = b49f65a0c5df83de85df4f985337e2eb
md5sums = a2e8f7e419de1b864c31342003ebcd4d
+ md5sums = 0add7095857fe517d35abdbd79e25259
pkgname = njam
diff --git a/PKGBUILD b/PKGBUILD
index a4158fb7a8e1..89ffaeb64c14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Contributor: Stefano "GeniE" Faraone <xgotux@gmail.com>
+# Maintainer: Markus Heidelberg <markus dot heidelberg at web dot de>
pkgname=njam
pkgver=1.25
-pkgrel=6
+pkgrel=7
pkgdesc="Full-featured cross-platform pacman-like game"
url="http://njam.sourceforge.net/"
license=('GPL')
arch=('i686' 'x86_64')
depends=('sdl_image' 'sdl_mixer' 'sdl_net')
-source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz njam.desktop)
-md5sums=('b49f65a0c5df83de85df4f985337e2eb' 'a2e8f7e419de1b864c31342003ebcd4d')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz njam.desktop njam-1.25-gcc45-archlinux.patch)
+md5sums=('b49f65a0c5df83de85df4f985337e2eb' 'a2e8f7e419de1b864c31342003ebcd4d' '0add7095857fe517d35abdbd79e25259')
build() {
cd ${srcdir}/${pkgname}-${pkgver}-src
+ patch -p0 < ${srcdir}/njam-1.25-gcc45-archlinux.patch
./configure --prefix=/usr
make clean || return 1 # Delete the binary files which are distributed in the tar file
make || return 1
diff --git a/njam-1.25-gcc45-archlinux.patch b/njam-1.25-gcc45-archlinux.patch
new file mode 100644
index 000000000000..763799e7aa28
--- /dev/null
+++ b/njam-1.25-gcc45-archlinux.patch
@@ -0,0 +1,25 @@
+Fix buiding with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318411
+
+Adapted for Arch Linux.
+--- src/njamedit.cpp
++++ src/njamedit.cpp
+@@ -114,7 +114,7 @@
+ key = SDLK_a;
+ else if (CheckForSave())
+ {
+- LogFile::LogFile("Saving maps");
++ LogFile("Saving maps");
+ m_Maps.Save(filename);
+ level_type_was = level_type;
+ changed = false;
+@@ -139,7 +139,7 @@
+ "levels/%s.%s",
+ #endif
+ filename, types[level_type]);
+- LogFile::LogFile("Saving maps");
++ LogFile("Saving maps");
+ m_Maps.Save(buf);
+ level_type_was = level_type;
+ changed = false;