summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-07-30 03:00:45 +0200
committerhaawda2019-07-30 03:00:45 +0200
commit0013ef00122446cf00db77c5a05e1344866c1074 (patch)
tree2076ae4fe884a1ea9ffb1e0745bb775dea899295
parent83f81d0d4fa74c469bb67e4b325e420b2785740d (diff)
downloadaur-0013ef00122446cf00db77c5a05e1344866c1074.tar.gz
remove build function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 4 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b5574dcb933..af9e401743cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nlohmann-json
pkgdesc = Header-only JSON library for Modern C++
pkgver = 3.7.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/nlohmann/json
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 0356ada8b7dd..04e42af970dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nlohmann-json
pkgver=3.7.0
-pkgrel=3
+pkgrel=4
pkgdesc="Header-only JSON library for Modern C++"
url="https://github.com/nlohmann/json"
license=('MIT')
@@ -11,24 +11,17 @@ makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('d51a3a8d3efbb1139d7608e28782ea9efea7e7933157e8ff8184901efd8ee760')
-build() {
+check() {
[[ -d nlohmann-json-build ]] || mkdir -p nlohmann-json-build
cd nlohmann-json-build
cmake "$srcdir"/json-$pkgver \
- -DBUILD_TESTING=OFF \
+ -DBUILD_TESTING=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib
make
}
-check() {
- cd nlohmann-json-build
- cmake -DBUILD_TESTING=ON "$srcdir"/json-$pkgver
- make
- ctest
-}
-
package() {
cd nlohmann-json-build
make DESTDIR="$pkgdir" install