summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-09-27 11:19:38 +0200
committerbartus2017-09-27 11:19:38 +0200
commit8e2ddacd5cd7e868514d7bba8771d9ecb7dff4b9 (patch)
treedf02f9a94f7c6d844cc6d91c7b44039dee7072e4
downloadaur-8e2ddacd5cd7e868514d7bba8771d9ecb7dff4b9.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7c09c181d8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nlohmann-json
+ pkgdesc = JSON for Modern C++, whole code consistes of a single header file
+ pkgver = 2.1.1.r487.gb05ea3de
+ pkgrel = 1
+ url = https://github.com/nlohmann/json
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ source = nlohmann-json::git+https://github.com/nlohmann/json.git
+ md5sums = SKIP
+
+pkgname = nlohmann-json
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66184f85f654
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: bartus <aur@bartus.33mail.com>
+pkgname=nlohmann-json
+#for fragment you can use one of: #commit=, #tag=, #branch=
+#fragment=
+pkgver=2.1.1.r487.gb05ea3de
+pkgrel=1
+pkgdesc="JSON for Modern C++, whole code consistes of a single header file"
+arch=(any)
+url="https://github.com/nlohmann/json"
+license=(MIT)
+makedepends=(git cmake)
+source=(${pkgname}::git+https://github.com/nlohmann/json.git${fragment})
+md5sums=(SKIP) #generate with 'makepkg -g'
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${pkgname}
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+check() {
+ cd ${pkgname}/build
+ make test
+}
+
+package() {
+ cd ${pkgname}/build
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "../LICENSE.MIT" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: