summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-05-11 20:00:40 +0200
committerhaawda2019-05-11 20:00:40 +0200
commitd0f0f3b9759f9324e0d0e97b40caa4fe19e37b50 (patch)
tree6acc60f5e6f4073c6d44cf6897698f9cf68d3267
parent73e28a846ba3bf0b4ff5df80800b7790dd8f0cb4 (diff)
downloadaur-d0f0f3b9759f9324e0d0e97b40caa4fe19e37b50.tar.gz
adopted, set arch to any
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b1d8eda9a1e7..810f43c1279f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,5 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=nlohmann-json
pkgver=3.6.1
pkgrel=1
@@ -10,24 +12,24 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkg
sha256sums=('SKIP')
build() {
- mkdir -p "$srcdir/nlohmann-json-build"
- cd "$srcdir/nlohmann-json-build"
+ [[ -d nlohmann-json-build ]] || mkdir -p nlohmann-json-build
+ cd nlohmann-json-build
- cmake "$srcdir/json-$pkgver" \
+ cmake "$srcdir"/json-$pkgver \
-DBUILD_TESTING=OFF \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
check() {
- cd "$srcdir/nlohmann-json-build"
- cmake -DBUILD_TESTING=ON "$srcdir/json-$pkgver"
+ cd nlohmann-json-build
+ cmake -DBUILD_TESTING=ON "$srcdir"/json-$pkgver
make
ctest
}
package() {
- cd "$srcdir/nlohmann-json-build"
+ cd nlohmann-json-build
make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/json-$pkgver/LICENSE.MIT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.MIT"
+ install -Dm644 "$srcdir"/json-$pkgver/LICENSE.MIT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.MIT
}