summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesin2018-01-04 15:15:12 -0500
committerJesin2018-01-04 15:15:12 -0500
commit9c63c5674d3ec85dc6318f60c55dd429e9e065f0 (patch)
treee751debb2ae9b19a49110eefb73a61aadfd223fd
parent790fb8b1cca2dea729319e586aa8f979c349925b (diff)
downloadaur-9c63c5674d3ec85dc6318f60c55dd429e9e065f0.tar.gz
move provides and conflicts to toplevel
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7168bd3f44d..e169dcd7887a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,10 +7,10 @@ pkgbase = nlohmann-json-git
license = MIT
makedepends = cmake
makedepends = git
+ provides = nlohmann-json=3.0.1
+ conflicts = nlohmann-json
source = git+https://github.com/nlohmann/json
sha256sums = SKIP
pkgname = nlohmann-json-git
- provides = nlohmann-json=3.0.1
- conflicts = nlohmann-json
diff --git a/PKGBUILD b/PKGBUILD
index e3b9ca1f0adf..3a87f4e746bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,8 @@ url='https://github.com/nlohmann/json'
license=(MIT)
arch=(x86_64)
makedepends=(cmake git)
+provides=("$_name=${pkgver%%+*}")
+conflicts=("$_name")
source=("git+$url")
sha256sums=(SKIP)
@@ -32,8 +34,6 @@ check() {
}
package() {
- provides=("$_name=${pkgver%%+*}")
- conflicts=("$_name")
cd build
make "DESTDIR=$pkgdir" install
install -Dm644 "-t$pkgdir/usr/share/licenses/$_name" ../json/LICENSE.MIT