summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesin2018-12-24 18:09:27 -0500
committerJesin2018-12-24 18:09:27 -0500
commitd5fc23994243e0d826323e9610fb2b95eef3a884 (patch)
tree2ec8edaa530d03f51331da8836b0d0d8ec99944d
parentcbc2a4d6aa9a5e08f47ca36814a21e15dfe5abcd (diff)
downloadaur-d5fc23994243e0d826323e9610fb2b95eef3a884.tar.gz
v3.5.0; don't build tests with makepkg --nocheck
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4149ff78838a..dbce124c944e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = nlohmann-json-git
pkgdesc = Header-only JSON library for Modern C++
- pkgver = 3.4.0
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/nlohmann/json
arch = x86_64
license = MIT
makedepends = cmake
makedepends = git
- provides = nlohmann-json=3.3.0
+ provides = nlohmann-json=3.5.0
conflicts = nlohmann-json
source = git+https://github.com/nlohmann/json
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b152cdb7ab2e..63c564231111 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Eduardo Sánchez Muñoz
pkgname=nlohmann-json-git
_name="${pkgname%-git}"
-pkgver=3.4.0
+pkgver=3.5.0
pkgrel=1
pkgdesc='Header-only JSON library for Modern C++'
url='https://github.com/nlohmann/json'
@@ -21,15 +21,22 @@ pkgver() {
printf %s "${v//-/+}"
}
+_cmake_flags=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_INSTALL_PREFIX=/usr
+)
+
build() {
mkdir build
cd build
- cmake ../json -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake ../json "${_cmake_flags[@]}" -DBUILD_TESTING=OFF
make
}
check() {
cd build
+ cmake ../json "${_cmake_flags[@]}" -DBUILD_TESTING=ON
+ make
ctest --output-on-failure
}