summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-11-16 18:00:05 -0500
committerChris Severance2019-11-16 18:00:05 -0500
commit9e31c637043895a3c0397cd0bc4567c937674ed6 (patch)
treed10dd00237212d04660c759d4da80632ec274567
parent31d46ad54248e953bb8da272e8b973452ad9a096 (diff)
downloadaur-nmap-svn.tar.gz
autu: Update to 7.80.r37760-1
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD97
2 files changed, 68 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f37a10a68286..0d4aad610896 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,26 @@
+# Generated by mksrcinfo v8
+# Sat Nov 16 23:00:04 UTC 2019
pkgbase = nmap-svn
- pkgdesc = A network exploration tool and security/port scanner
- pkgver = r35224
+ pkgdesc = Utility for network discovery and security auditing
+ pkgver = 7.80.r37760
pkgrel = 1
- url = httpss://nmap.org
- arch = armv6h
- arch = armv7h
- arch = i686
+ url = https://nmap.org/
arch = x86_64
- license = GPLv2
- license = custom:nmap
- makedepends = python2
- makedepends = subversion
+ license = GPL2
+ makedepends = pygtk
+ makedepends = svn
depends = pcre
depends = openssl
- depends = libpcap>=1.0.0
- depends = lua52
- depends = libnl
+ depends = lua
optdepends = pygtk: zenmap
optdepends = sudo: privilege escalation for zenmap
optdepends = xterm: privilege escalation for zenmap
- optdepends = kdebase-runtime: privilege escalation for zenmap
- optdepends = gksu: privilege escalation for zenmap
- provides = nmap
+ optdepends = kde-cli-tools: privilege escalation for zenmap
+ provides = nmap=7.80
conflicts = nmap
- options = !makeflags
- source = svn+https://svn.nmap.org/nmap/
+ source = nmap-svn::svn+https://svn.nmap.org/nmap/
+ md5sums = SKIP
+ sha256sums = SKIP
sha512sums = SKIP
pkgname = nmap-svn
diff --git a/PKGBUILD b/PKGBUILD
index 5536a5a64e64..471ee7201fc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,78 @@
-# Maintainer: David Manouchehri <manouchehri@riseup.net>
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: David Manouchehri <manouchehri@riseup.net>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
# Contributor: Ermenegildo Fiorito <fiorito.g@gmail.com>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Rickey Visinski <rickeyvisinski at gmail.com>
-_svnname='nmap'
-pkgname="${_svnname}-svn"
-pkgver=r35224
+set -u
+pkgname='nmap'
+#pkgname+='-git'
+pkgname+='-svn'
+pkgver=7.80.r37760
pkgrel=1
-pkgdesc="A network exploration tool and security/port scanner"
-arch=('armv6h' 'armv7h' 'i686' 'x86_64')
-url="httpss://nmap.org"
-license=('GPLv2' 'custom:nmap')
-depends=('pcre' 'openssl' 'libpcap>=1.0.0' 'lua52' 'libnl')
-makedepends=('python2' 'subversion') # python is needed for zenmap
+pkgdesc='Utility for network discovery and security auditing'
+url='https://nmap.org/'
+arch=('x86_64')
+license=('GPL2')
+depends=('pcre' 'openssl' 'lua')
+makedepends=('pygtk')
optdepends=('pygtk: zenmap'
'sudo: privilege escalation for zenmap'
'xterm: privilege escalation for zenmap'
- 'kdebase-runtime: privilege escalation for zenmap'
- 'gksu: privilege escalation for zenmap')
-options=('!makeflags')
-source=("svn+https://svn.nmap.org/${_svnname}/")
-provides=("${_svnname}")
-conflicts=("${_svnname}")
-sha512sums=('SKIP')
+ 'kde-cli-tools: privilege escalation for zenmap')
+_srcdir="${pkgname%-*}-${pkgver}"
+source=("https://nmap.org/dist/${_srcdir}.tar.bz2")
+md5sums=('d37b75b06d1d40f27b76d60db420a1f5')
+sha256sums=('fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa')
+sha512sums=('d4384d3ebf4f3abf3588eed5433f733874ecdceb9342a718dc36db19634b0cc819d73399974eb0a9a9c9dd9e5c88473e07644ec91db28b0c072552b54430be6b')
+if [ "${pkgname%-*}" != "${pkgname}" ]; then
+ _srcdir="${pkgname}"
+ case "${pkgname}" in
+ *'-git') source[0]="${_srcdir}::git://github.com/nmap/nmap.git"; makedepends+=('git');;
+ *'-svn') source[0]="${_srcdir}::svn+https://svn.nmap.org/${pkgname%-svn}/"; makedepends+=('svn');;
+ esac
+ md5sums[0]='SKIP'
+ sha256sums[0]='SKIP'
+ sha512sums[0]='SKIP'
+ provides=("${pkgname%-*}=${pkgver%%.r*}")
+ conflicts=("${pkgname%-*}")
pkgver() {
- cd "${srcdir}/${_svnname}"
- local ver="$(svnversion)"
- printf "r%s" "${ver//[[:alpha:]]}"
+ set -u
+ cd "${_srcdir}"
+ local _v='s:^#define NMAP_UPDATE_CHANNEL "([^"]+)".*$:\1:p'
+ _v="$(sed -E -n -e "${_v}" 'nmap.h')"
+ case "${pkgname}" in
+ *'-git') printf '%s.r%s.g%s' "${_v}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)";;
+ *'-svn') printf '%s.r%s' "${_v}" "$(svnversion)";;
+ esac
+ set +u
}
+fi
build() {
- cd "${srcdir}/${_svnname}"
-
- sed -i 's# @LIBS@# @LIBS@ -lnl-3#' ncat/Makefile.in
-
+ set +u
+ cd "${_srcdir}"
+ export PYTHON='python2'
./configure \
- --prefix=/usr \
- PYTHON="python2" \
- --libexecdir=/usr/lib \
- --mandir=/usr/share/man \
- --with-libpcap=included \
- --with-openssl=/usr \
- --with-liblua=included
+ --prefix='/usr' \
+ --libexecdir='/usr/lib' \
+ --mandir='/usr/share/man' \
+ --with-libpcap='included' \
- cd "ncat/"
- make
- cd "../"
make
+ set -u
}
package() {
- cd "${srcdir}/${_svnname}"
+ set +u
+ cd "${_srcdir}"
make DESTDIR="${pkgdir}" install
- python2 -m compileall "${pkgdir}/usr/lib/python2.7/site-packages/zenmapCore"
-
- # remove zenmap uninstall script
- rm "${pkgdir}/usr/bin/uninstall_zenmap"
-
- # install custom GPL2 license
+ rm "${pkgdir}"/usr/bin/uninstall_*
install -Dm644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 -m compileall "${pkgdir}/usr/lib/python2.7/site-packages/zenmapCore"
+ set -u
}
-
-# vim:set et sw=2 sts=2 tw=80:
+set +u