summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Manouchehri2015-09-06 15:15:57 -0400
committerDavid Manouchehri2015-09-06 15:59:13 -0400
commit31d46ad54248e953bb8da272e8b973452ad9a096 (patch)
treec21c7312a11872a67e03102ae24db17f8bffe598
downloadaur-31d46ad54248e953bb8da272e8b973452ad9a096.tar.gz
Created package.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD67
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f37a10a68286
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = nmap-svn
+ pkgdesc = A network exploration tool and security/port scanner
+ pkgver = r35224
+ pkgrel = 1
+ url = httpss://nmap.org
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ license = custom:nmap
+ makedepends = python2
+ makedepends = subversion
+ depends = pcre
+ depends = openssl
+ depends = libpcap>=1.0.0
+ depends = lua52
+ depends = libnl
+ optdepends = pygtk: zenmap
+ optdepends = sudo: privilege escalation for zenmap
+ optdepends = xterm: privilege escalation for zenmap
+ optdepends = kdebase-runtime: privilege escalation for zenmap
+ optdepends = gksu: privilege escalation for zenmap
+ provides = nmap
+ conflicts = nmap
+ options = !makeflags
+ source = svn+https://svn.nmap.org/nmap/
+ sha512sums = SKIP
+
+pkgname = nmap-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5536a5a64e64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: David Manouchehri <manouchehri@riseup.net>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Contributor: Ermenegildo Fiorito <fiorito.g@gmail.com>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Rickey Visinski <rickeyvisinski at gmail.com>
+
+_svnname='nmap'
+pkgname="${_svnname}-svn"
+pkgver=r35224
+pkgrel=1
+pkgdesc="A network exploration tool and security/port scanner"
+arch=('armv6h' 'armv7h' 'i686' 'x86_64')
+url="httpss://nmap.org"
+license=('GPLv2' 'custom:nmap')
+depends=('pcre' 'openssl' 'libpcap>=1.0.0' 'lua52' 'libnl')
+makedepends=('python2' 'subversion') # python is needed for zenmap
+optdepends=('pygtk: zenmap'
+ 'sudo: privilege escalation for zenmap'
+ 'xterm: privilege escalation for zenmap'
+ 'kdebase-runtime: privilege escalation for zenmap'
+ 'gksu: privilege escalation for zenmap')
+options=('!makeflags')
+source=("svn+https://svn.nmap.org/${_svnname}/")
+provides=("${_svnname}")
+conflicts=("${_svnname}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_svnname}"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "${srcdir}/${_svnname}"
+
+ sed -i 's# @LIBS@# @LIBS@ -lnl-3#' ncat/Makefile.in
+
+ ./configure \
+ --prefix=/usr \
+ PYTHON="python2" \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --with-libpcap=included \
+ --with-openssl=/usr \
+ --with-liblua=included
+
+ cd "ncat/"
+ make
+ cd "../"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_svnname}"
+ make DESTDIR="${pkgdir}" install
+ python2 -m compileall "${pkgdir}/usr/lib/python2.7/site-packages/zenmapCore"
+
+ # remove zenmap uninstall script
+ rm "${pkgdir}/usr/bin/uninstall_zenmap"
+
+ # install custom GPL2 license
+ install -Dm644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set et sw=2 sts=2 tw=80: