summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-09-05 05:33:40 -0400
committerDaniel Moch2018-09-05 05:33:40 -0400
commit105a85be163996e89dc298bfed5322c75365525e (patch)
tree12812b0c85eb108b43c9fac5e3199e3e94b63055
parent22d2b88df0b39b6acfc8260e2e107256a55b7efa (diff)
downloadaur-105a85be163996e89dc298bfed5322c75365525e.tar.gz
upgpkg: nncli 0.2.0-2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 23 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 042f7496d459..79b6211e5fce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = nncli
pkgdesc = NextCloud Notes Command Line Interface
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/djmoch/nncli
arch = any
license = MIT
makedepends = python-pip
+ makedepends = flit
+ makedepends = python-sphinx
+ makedepends = gzip
depends = python
depends = python-urwid
depends = python-requests
depends = python-appdirs
- noextract = nncli-0.2.0-py3-none-any.whl
- source = nncli-0.2.0-py3-none-any.whl::https://files.pythonhosted.org/packages/py3/n/nncli/nncli-0.2.0-py3-none-any.whl
- source = LICENSE::https://raw.githubusercontent.com/djmoch/nncli/v0.2.0/LICENSE
- sha256sums = e8f07c22f1d8870e23e76c082a113eea2d0bc3e003525c25ac2e0bba1688606a
- sha256sums = 5240402e10b059c75958f58a489e92eaf994c7274f0b8d566f95bb35dda62383
+ source = nncli-0.2.0.tar.gz::https://files.pythonhosted.org/packages/source/n/nncli/nncli-0.2.0.tar.gz
+ sha256sums = f6264b49937eeaf8861829dd8b071c73923066b5ecff9cfb29f3784ed9524667
pkgname = nncli
diff --git a/PKGBUILD b/PKGBUILD
index a7bd30c8239d..e37659a91464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
# Maintainer: Daniel Moch <daniel@danielmoch.com>
pkgname=nncli
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="NextCloud Notes Command Line Interface"
arch=('any')
url="https://github.com/djmoch/${pkgname}"
license=('MIT')
depends=('python' 'python-urwid' 'python-requests' 'python-appdirs')
-makedepends=('python-pip')
-source=("${pkgname}-${pkgver}-py3-none-any.whl::https://files.pythonhosted.org/packages/py3/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}-py3-none-any.whl"
- "LICENSE::https://raw.githubusercontent.com/djmoch/${pkgname}/v${pkgver}/LICENSE")
-sha256sums=('e8f07c22f1d8870e23e76c082a113eea2d0bc3e003525c25ac2e0bba1688606a'
- '5240402e10b059c75958f58a489e92eaf994c7274f0b8d566f95bb35dda62383')
-noextract=("${pkgname}-${pkgver}-py3-none-any.whl")
+makedepends=('python-pip' 'flit' 'python-sphinx' 'gzip')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('f6264b49937eeaf8861829dd8b071c73923066b5ecff9cfb29f3784ed9524667')
+
+build()
+{
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ flit build --format wheel
+ cd "${srcdir}/${pkgname}-${pkgver}/docs"
+ sphinx-build -M man source build
+ gzip build/man/nncli.1
+}
package()
{
- cd "${srcdir}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- pip install -I --no-warn-script-location --isolated --no-deps --compile --root="${pkgdir}" ${pkgname}-${pkgver}-py3-none-any.whl
+ install -Dm644 docs/build/man/nncli.1.gz "${pkgdir}/usr/share/man/man1/nncli.1.gz"
+ pip install -I --no-warn-script-location --isolated --no-deps --compile --root="${pkgdir}" dist/${pkgname}-${pkgver}-py3-none-any.whl
}
-
-# vim: ft=PKGBUILD ts=2 sw=2 et
+# vim: ft=PKGBUILD sts=2 sw=2 et