summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-09-03 09:25:57 -0400
committerDaniel Moch2018-09-03 09:25:57 -0400
commit22d2b88df0b39b6acfc8260e2e107256a55b7efa (patch)
tree010a63508afca2b473dac2fa1cf51d9f7db40c92
parent0dac7b3c6a5ccc9ff746d6017f77edd5c6a6a676 (diff)
downloadaur-22d2b88df0b39b6acfc8260e2e107256a55b7efa.tar.gz
upgpkg: nncli 0.2.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
3 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49c555bff01b..042f7496d459 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = nncli
pkgdesc = NextCloud Notes Command Line Interface
- pkgver = 0.1.2
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/djmoch/nncli
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-pip
+ depends = python
depends = python-urwid
depends = python-requests
- source = nncli-0.1.2.tar.gz::https://files.pythonhosted.org/packages/source/n/nncli/nncli-0.1.2.tar.gz
- sha256sums = 6bec77deb14b2c09c73d30b500e7e0ed9f1bf4d28fd6bfb5386eda2a6499da97
+ depends = python-appdirs
+ noextract = nncli-0.2.0-py3-none-any.whl
+ source = nncli-0.2.0-py3-none-any.whl::https://files.pythonhosted.org/packages/py3/n/nncli/nncli-0.2.0-py3-none-any.whl
+ source = LICENSE::https://raw.githubusercontent.com/djmoch/nncli/v0.2.0/LICENSE
+ sha256sums = e8f07c22f1d8870e23e76c082a113eea2d0bc3e003525c25ac2e0bba1688606a
+ sha256sums = 5240402e10b059c75958f58a489e92eaf994c7274f0b8d566f95bb35dda62383
pkgname = nncli
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..c8ec0a64237c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
pkg/
src/
*.tar.*
+LICENSE
+*.whl
diff --git a/PKGBUILD b/PKGBUILD
index 26f50988def9..a7bd30c8239d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Daniel Moch <daniel@danielmoch.com>
pkgname=nncli
-pkgver=0.1.2
+pkgver=0.2.0
pkgrel=1
pkgdesc="NextCloud Notes Command Line Interface"
arch=('any')
url="https://github.com/djmoch/${pkgname}"
license=('MIT')
-depends=('python-urwid' 'python-requests')
-makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('6bec77deb14b2c09c73d30b500e7e0ed9f1bf4d28fd6bfb5386eda2a6499da97')
+depends=('python' 'python-urwid' 'python-requests' 'python-appdirs')
+makedepends=('python-pip')
+source=("${pkgname}-${pkgver}-py3-none-any.whl::https://files.pythonhosted.org/packages/py3/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}-py3-none-any.whl"
+ "LICENSE::https://raw.githubusercontent.com/djmoch/${pkgname}/v${pkgver}/LICENSE")
+sha256sums=('e8f07c22f1d8870e23e76c082a113eea2d0bc3e003525c25ac2e0bba1688606a'
+ '5240402e10b059c75958f58a489e92eaf994c7274f0b8d566f95bb35dda62383')
+noextract=("${pkgname}-${pkgver}-py3-none-any.whl")
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+package()
+{
+ cd "${srcdir}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ pip install -I --no-warn-script-location --isolated --no-deps --compile --root="${pkgdir}" ${pkgname}-${pkgver}-py3-none-any.whl
}
-package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
# vim: ft=PKGBUILD ts=2 sw=2 et