summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-09-17 06:27:23 -0400
committerDaniel Moch2018-09-17 06:27:23 -0400
commit4fe3cb3ee3e0f88b69d0ea3154d054f410d173ec (patch)
treefc7944905541ad4377f6328bc5f2a1ed0674d428
parent8a28803dad9b542da721c06d7d97bdb80e811ad7 (diff)
downloadaur-4fe3cb3ee3e0f88b69d0ea3154d054f410d173ec.tar.gz
upgpkg: nncli 0.3.0-2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33258fad3e97..970231e00d41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = nncli
pkgdesc = NextCloud Notes Command Line Interface
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/djmoch/nncli
arch = any
license = MIT
makedepends = python-pip
makedepends = flit
makedepends = python-sphinx
- makedepends = gzip
depends = python
depends = python-urwid
depends = python-requests
diff --git a/PKGBUILD b/PKGBUILD
index e0e372f92c98..048762590a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Moch <daniel@danielmoch.com>
pkgname=nncli
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="NextCloud Notes Command Line Interface"
arch=('any')
url="https://github.com/djmoch/${pkgname}"
@@ -11,7 +11,7 @@ depends=('python'
'python-requests'
'python-appdirs'
'python-click')
-makedepends=('python-pip' 'flit' 'python-sphinx' 'gzip')
+makedepends=('python-pip' 'flit' 'python-sphinx')
source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('78d2130395c34877fbae5cf133d588bfaa0b4d03f56935253ea950f1f9aa1190')
@@ -21,14 +21,13 @@ build()
flit build --format wheel
cd "${srcdir}/${pkgname}-${pkgver}/docs"
sphinx-build -M man source build
- gzip build/man/nncli.1
}
package()
{
cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 docs/build/man/nncli.1.gz "${pkgdir}/usr/share/man/man1/nncli.1.gz"
+ install -Dm644 docs/build/man/nncli.1 "${pkgdir}/usr/share/man/man1/nncli.1"
pip install -I --no-warn-script-location --isolated --no-deps --compile --root="${pkgdir}" dist/${pkgname}-${pkgver}-py3-none-any.whl
}