summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-09-05 05:12:18 -0400
committerDaniel Moch2018-09-05 05:12:18 -0400
commit199aee557f6a6c3c087b63527d7c08ec44bf5c9f (patch)
tree0ec0bddae9b75508b3af26a99dd1a24cabb20a56
parent076370f4a3cce63ee37e36a4c12aee264554ae0b (diff)
downloadaur-199aee557f6a6c3c087b63527d7c08ec44bf5c9f.tar.gz
upgpkg: nncli-git v0.2.0.r8.gccbf6c7-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc49dd05c585..ede2ca8557f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nncli-git
pkgdesc = NextCloud Notes Command Line Interface
- pkgver = v0.2.0.r0.g4a23f7b
+ pkgver = v0.2.0.r8.gccbf6c7
pkgrel = 1
url = https://github.com/djmoch/nncli
arch = any
@@ -10,6 +10,8 @@ pkgbase = nncli-git
makedepends = python-pip
makedepends = sed
makedepends = grep
+ makedepends = python-sphinx
+ makedepends = gzip
depends = python
depends = python-urwid
depends = python-requests
diff --git a/PKGBUILD b/PKGBUILD
index 88af323f852c..2a3b2e772fc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Moch <daniel@danielmoch.com>
_name=nncli
pkgname=nncli-git
-pkgver=v0.2.0.r0.g4a23f7b
+pkgver=v0.2.0.r8.gccbf6c7
pkgrel=1
pkgdesc="NextCloud Notes Command Line Interface"
arch=('any')
@@ -10,7 +10,7 @@ provides=('nncli')
conflicts=('nncli')
license=('MIT')
depends=('python' 'python-urwid' 'python-requests' 'python-appdirs')
-makedepends=('flit' 'git' 'python-pip' 'sed' 'grep')
+makedepends=('flit' 'git' 'python-pip' 'sed' 'grep' 'python-sphinx' 'gzip')
source=("git+${url}.git")
sha256sums=('SKIP')
@@ -24,6 +24,9 @@ build()
{
cd "${srcdir}/${_name}"
flit build
+ cd "${srcdir}/${_name}/docs"
+ sphinx-build -M man source build
+ gzip build/man/nncli.1
}
package()
@@ -31,6 +34,7 @@ package()
cd "${srcdir}/${_name}"
_ver=$(echo ${pkgver} | grep -Eo '[0-9]+\.[0-9]+\.[0-9]')
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 docs/build/man/nncli.1.gz "${pkgdir}/usr/share/man/man1/nncli.1.gz"
pip install -I --no-warn-script-location --isolated --no-deps --compile --root="${pkgdir}" dist/${_name}-${_ver}-py3-none-any.whl
}