summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPřemysl Janouch2016-10-12 16:01:38 +0200
committerPřemysl Janouch2016-10-12 16:01:38 +0200
commit8fd9848a73b32b4bdd2ffb4894a45c279759c4e4 (patch)
treec7ebaf243f0bd32949c1a389404e4ca0e9f34f7b
downloadaur-8fd9848a73b32b4bdd2ffb4894a45c279759c4e4.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c74159351d9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = nncmpp-git
+ pkgdesc = MPD client
+ pkgver = r61.0999159
+ pkgrel = 1
+ url = https://github.com/pjanouch/nncmpp
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ makedepends = pkg-config
+ makedepends = git
+ makedepends = help2man
+ depends = readline
+ depends = ncurses
+ depends = libunistring
+ depends = curl
+ provides = nncmpp
+ conflicts = nncmpp
+ options = zipman
+ source = git+https://github.com/pjanouch/nncmpp.git
+ md5sums = SKIP
+
+pkgname = nncmpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2618e8a39b02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Přemysl Janouch <p.janouch@gmail.com>
+pkgname=nncmpp-git
+_pkgname=nncmpp
+pkgver=r61.0999159
+pkgrel=1
+pkgdesc="MPD client"
+url="https://github.com/pjanouch/nncmpp"
+arch=('i686' 'x86_64')
+license=('BSD')
+options=(zipman)
+conflicts=('nncmpp')
+provides=('nncmpp')
+makedepends=('cmake' 'pkg-config' 'git' 'help2man')
+depends=('readline' 'ncurses' 'libunistring' 'curl')
+source=("git+https://github.com/pjanouch/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ rm -rf "$srcdir/$_pkgname-build"
+ mkdir "$srcdir/$_pkgname-build"
+ cd "$srcdir/$_pkgname-build"
+ cmake "$srcdir/$_pkgname" -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-build"
+ make install DESTDIR=$pkgdir
+}