summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Kuc2019-08-27 22:52:18 +0100
committerMichael Kuc2019-08-27 22:52:18 +0100
commit6b00b76964e2cf8829114c11d193b28c0180896a (patch)
treebc9451a8910686b7240122137c05d84750bd2ecf
parent8be885422e6f4f21f523576e933d147d8bf72d67 (diff)
downloadaur-6b00b76964e2cf8829114c11d193b28c0180896a.tar.gz
Fix package versioning.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd8dc79206e2..3258576e990e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nngpp-git
pkgdesc = C++ wrapper around the nanomsg NNG API
- pkgver = nng.v1.1.1.r13.g3351f54
+ pkgver = 1.1.1133351f54
pkgrel = 1
epoch = 1
url = https://github.com/cwzx/nngpp
diff --git a/PKGBUILD b/PKGBUILD
index 4e3f6c427aa5..e23314612a08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Kuc <michaelkuc6 at gmail dot com>
_pkgname=nngpp
pkgname=${_pkgname}-git
-pkgver=nng.v1.1.1.r13.g3351f54
+pkgver=1.1.1133351f54
pkgrel=1
pkgdesc="C++ wrapper around the nanomsg NNG API "
arch=('x86_64')
@@ -17,7 +17,7 @@ source=("${_pkgname}::git+https://github.com/cwzx/nngpp.git")
pkgver() {
cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | tr -d 'nng\-v' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -33,9 +33,9 @@ check() {
package() {
cd "${_pkgname}"
- install -dm644 "${pkgdir}/usr/include"
+ install -dm755 "${pkgdir}/usr/include"
cp -r include "${pkgdir}/usr"
- chmod -R 644 "${pkgdir}/usr/include"
+ chmod -R 644 "${pkgdir}/usr/include/${_pkgname}"
install -m644 -D "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -m644 -D "readme.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}