summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreNV252022-10-21 00:38:24 +0530
committereNV252022-10-21 00:38:24 +0530
commitc5c3d328ab6ae1a8f98585a73ecfcd2acc0337a4 (patch)
tree0828fc9c2b8a88256a5e6f02d2f859a0014ef083
parent9e3173dcaf9d21beb8980d9d5c4466a7e934796a (diff)
downloadaur-c5c3d328ab6ae1a8f98585a73ecfcd2acc0337a4.tar.gz
upgpkg: nnn-git 4.6.r48.gf89ba775-1
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD53
2 files changed, 31 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e74fb7e3138..7699a9e26cfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = nnn-git
pkgdesc = The fastest terminal file manager ever written.
- pkgver = 2.8.r2.gc139178
+ pkgver = 4.6.r48.gf89ba775
pkgrel = 1
url = https://github.com/jarun/nnn
arch = x86_64
license = BSD
makedepends = git
depends = bash
+ depends = sed
optdepends = atool: for more archive formats
optdepends = libarchive: for more archive formats
optdepends = zip: for zip archive format
@@ -22,4 +23,3 @@ pkgbase = nnn-git
md5sums = SKIP
pkgname = nnn-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 44e9bd68b94c..26ba1350533d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
-# Contributor:
+# Maintainer: eNV25 <env252525@gmail.com>
+# Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=nnn-git
-pkgver=2.8.r2.gc139178
+pkgver=4.6.r48.gf89ba775
pkgrel=1
pkgdesc="The fastest terminal file manager ever written."
arch=(x86_64)
url='https://github.com/jarun/nnn'
license=(BSD)
-depends=('bash')
+depends=(bash sed)
optdepends=(
- 'atool: for more archive formats'
- 'libarchive: for more archive formats'
- 'zip: for zip archive format'
- 'unzip: for zip archive format'
- 'trash-cli: to trash files'
- 'sshfs: mount remotes'
- 'rclone: mount remotes'
- 'fuse2: unmount remotes'
- 'xdg-utils: desktop opener'
+ 'atool: for more archive formats'
+ 'libarchive: for more archive formats'
+ 'zip: for zip archive format'
+ 'unzip: for zip archive format'
+ 'trash-cli: to trash files'
+ 'sshfs: mount remotes'
+ 'rclone: mount remotes'
+ 'fuse2: unmount remotes'
+ 'xdg-utils: desktop opener'
)
makedepends=(git)
provides=(nnn)
@@ -27,26 +27,31 @@ source=("git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd nnn
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//g'
+ cd nnn
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//g'
}
prepare() {
- sed -i 's/install: all/install:/' nnn/Makefile
+ sed -i 's/install: all/install:/' nnn/Makefile
}
build() {
- cd nnn
- make
+ cd nnn
+ make
}
package() {
- cd nnn
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ cd nnn
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ make DESTDIR="${pkgdir}" PREFIX=/usr install-desktop
- install -Dm644 misc/auto-completion/fish/nnn.fish "${pkgdir}/usr/share/fish/vendor_completions.d/nnn.fish"
- install -Dm644 misc/auto-completion/bash/nnn-completion.bash "${pkgdir}/usr/share/bash-completion/completions/nnn"
- install -Dm644 misc/auto-completion/zsh/_nnn "${pkgdir}/usr/share/zsh/site-functions/_nnn"
+ install -Dm644 misc/auto-completion/fish/nnn.fish "${pkgdir}/usr/share/fish/vendor_completions.d/nnn.fish"
+ install -Dm644 misc/auto-completion/bash/nnn-completion.bash "${pkgdir}/usr/share/bash-completion/completions/nnn"
+ install -Dm644 misc/auto-completion/zsh/_nnn "${pkgdir}/usr/share/zsh/site-functions/_nnn"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 -t "${pkgdir}/usr/share/nnn/quitcd/" misc/quitcd/*
+
+ cp -a plugins "${pkgdir}/usr/share/nnn/plugins/"
+
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" LICENSE
}