summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-07 11:21:56 -0300
committerDaniel Bermond2017-05-07 11:21:56 -0300
commit8c6ec179e27090895c38fd76a0477760300ce1c1 (patch)
tree4c03ccce98dc43febe2907a6cfb069f228059a19
downloadaur-8c6ec179e27090895c38fd76a0477760300ce1c1.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD55
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f66669d70a68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun May 7 14:21:51 UTC 2017
+pkgbase = nnpack-git
+ pkgdesc = An acceleration package for neural network computations (git version)
+ pkgver = r230.32c1a9d
+ pkgrel = 1
+ url = https://github.com/Maratyszcza/NNPACK/
+ arch = i386
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = python2
+ makedepends = ninja
+ makedepends = confu2-git
+ makedepends = python2-peachpy-git
+ options = staticlibs
+ source = nnpack-git::git+https://github.com/Maratyszcza/NNPACK.git
+ sha256sums = SKIP
+
+pkgname = nnpack-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e03c4af3d71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+
+pkgname=nnpack-git
+pkgver=r230.32c1a9d
+pkgrel=1
+pkgdesc="An acceleration package for neural network computations (git version)"
+arch=('i386' 'x86_64')
+url="https://github.com/Maratyszcza/NNPACK/"
+license=('BSD')
+makedepends=(
+ # binary repositories:
+ 'git' 'python2' 'ninja'
+ # AUR:
+ 'confu2-git' 'python2-peachpy-git'
+)
+options=('staticlibs')
+source=("$pkgname"::"git+https://github.com/Maratyszcza/NNPACK.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ # git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+
+ confu2 setup
+ python2 ./configure.py #--enable-shared # https://github.com/Maratyszcza/NNPACK/issues/56
+ sed -i '/cflags[[:space:]]=[[:space:]]/s/$/ -fPIC/' build.ninja # add -fPIC
+ sed -i '/cxxflags[[:space:]]=[[:space:]]/s/$/ -fPIC/' build.ninja # add -fPIC
+ sed -i '/peachpy[[:space:]]=[[:space:]]python/s/python/python2/' build.ninja # use python2
+ ninja
+}
+
+package() {
+ cd "${pkgname}"
+
+ # directories creation
+ mkdir -p "${pkgdir}/usr/include/nnpack"
+ mkdir -p "${pkgdir}/usr/lib"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # include
+ install -D -m644 include/*.h "${pkgdir}/usr/include"
+ install -D -m644 include/nnpack/*.h "${pkgdir}/usr/include/nnpack"
+
+ # lib
+ install -D -m644 lib/libnnpack.a "${pkgdir}/usr/lib"
+
+ # license
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}