summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoshless2020-07-27 23:18:19 +0200
committerRoshless2020-07-27 23:18:19 +0200
commitfe4b3b8ca55f81df81366b4258ad008175604db5 (patch)
treef1a53c18332bfd0383a2b3ab058b575ca4283bda
downloadaur-fe4b3b8ca55f81df81366b4258ad008175604db5.tar.gz
Initial upload: nnrss-git 0.2.r0.gd339d95-1
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD41
-rw-r--r--nnrss.install11
-rw-r--r--nnrss.sysusers1
-rw-r--r--nnrss.tmpfiles1
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b88618af7081
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = nnrss-git
+ pkgdesc = Web/API RSS aggregator - git master
+ pkgver = 0.2.r0.gd339d95
+ pkgrel = 1
+ url = https://git.roshless.me/~roshless/nnrss
+ install = nnrss.install
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python-flask
+ depends = python-sqlalchemy
+ depends = python-werkzeug
+ depends = python-feedparser
+ depends = python-listparser
+ depends = python-apscheduler
+ depends = python-pyaml
+ depends = python-wtforms
+ provides = nnrss
+ conflicts = nnrss
+ source = nnrss-git::git+https://git.roshless.me/~roshless/nnrss
+ source = nnrss.sysusers
+ source = nnrss.tmpfiles
+ md5sums = SKIP
+ md5sums = 8b9a147720fbe9f6c013f6aa7dbb8140
+ md5sums = 364b51a829d7cf46a9557b97f8d3ce28
+
+pkgname = nnrss-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e043cde62adc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Roshless <pkg@roshless.com>
+
+pkgname=nnrss-git
+pkgver=0.2.r0.gd339d95
+pkgrel=1
+pkgdesc='Web/API RSS aggregator - git master'
+url='https://git.roshless.me/~roshless/nnrss'
+arch=('any')
+license=('GPL')
+depends=('python-flask' 'python-sqlalchemy' 'python-werkzeug'
+ 'python-feedparser' 'python-listparser' 'python-apscheduler'
+ 'python-pyaml' 'python-wtforms')
+makedepends=('python-setuptools' 'git')
+provides=('nnrss')
+conflicts=('nnrss')
+install='nnrss.install'
+source=("nnrss-git::git+https://git.roshless.me/~roshless/${pkgname%-git}"
+ "nnrss.sysusers"
+ "nnrss.tmpfiles")
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ install -Dm644 ${pkgname%-git}.sysusers "$pkgdir/usr/lib/sysusers.d/${pkgname%-git}.conf"
+ install -Dm644 ${pkgname%-git}.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/${pkgname%-git}.conf"
+
+ cd $pkgname
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+md5sums=('SKIP'
+ '8b9a147720fbe9f6c013f6aa7dbb8140'
+ '364b51a829d7cf46a9557b97f8d3ce28')
diff --git a/nnrss.install b/nnrss.install
new file mode 100644
index 000000000000..29203c9645ff
--- /dev/null
+++ b/nnrss.install
@@ -0,0 +1,11 @@
+post_install() {
+ chown -R nnrss:nnrss /var/lib/nnrss
+}
+
+post_upgrade() {
+ chown -R nnrss:nnrss /var/lib/nnrss
+}
+
+post_remove() {
+ echo 'You may want to remove nnrss user.'
+}
diff --git a/nnrss.sysusers b/nnrss.sysusers
new file mode 100644
index 000000000000..fc46c16ea7f5
--- /dev/null
+++ b/nnrss.sysusers
@@ -0,0 +1 @@
+u nnrss - "nnrss daemon user" /var/lib/nnrss
diff --git a/nnrss.tmpfiles b/nnrss.tmpfiles
new file mode 100644
index 000000000000..d954662e8f8f
--- /dev/null
+++ b/nnrss.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/nnrss 0700 nnrss nnrss -