summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2016-04-03 21:25:52 +0500
committerDmitry Kharitonov2016-04-03 21:25:52 +0500
commit13aa3d845bb7763c036efb6edc328fc3c0ca19f9 (patch)
treec217aed408fac9757348d1bbed9a646435c77357
downloadaur-13aa3d845bb7763c036efb6edc328fc3c0ca19f9.tar.gz
Adopted the package from AUR archive; switched to qt5
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9316f5ad465e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Apr 3 16:24:36 UTC 2016
+pkgbase = noblenote-git
+ pkgdesc = nobleNote aims to be a lightweight, open source alternative to Evernote and OneNote.
+ pkgver = 560.7b926f9
+ pkgrel = 2
+ url = http://qt-apps.org/content/show.php/nobleNote?content=157713
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = qt5-base qt5-tools
+ source = git+https://github.com/hakaishi/nobleNote.git
+ md5sums = SKIP
+
+pkgname = noblenote-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..032fcce4352c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dmitry Kharitonov <darksab0r at gmail com>
+# Contributor: archtux <antonio dot arias99999 at gmail dot com>
+
+pkgname=noblenote-git
+pkgver=560.7b926f9
+pkgrel=2
+pkgdesc="nobleNote aims to be a lightweight, open source alternative to Evernote and OneNote."
+url="http://qt-apps.org/content/show.php/nobleNote?content=157713"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('qt5-base qt5-tools')
+makedepends=('git')
+source=('git+https://github.com/hakaishi/nobleNote.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/nobleNote
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+
+build() {
+ cd $srcdir/nobleNote
+ qmake
+}
+
+package() {
+ cd $srcdir/nobleNote
+ make INSTALL_ROOT=$pkgdir install
+ # Desktop icon
+ install -Dm644 noblenote.desktop $pkgdir/usr/share/applications/noblenote.desktop
+ sed -i 's|Icon=noblenote|Icon=/usr/share/pixmaps/noblenote-icons/noblenote|' $pkgdir/usr/share/applications/noblenote.desktop
+}