summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2016-05-17 20:17:22 +0300
committerMantas Mikulėnas2016-05-17 20:17:22 +0300
commit64b350a2386ce5594e8b0ec28a3fbffc9c266c0e (patch)
treedbde4b730cfb5152e2471578cee9445c34fd52ba
parent32e9f6c0ade48dec8f76596dcee53fe2fc771057 (diff)
downloadaur-64b350a2386ce5594e8b0ec28a3fbffc9c266c0e.tar.gz
release 1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbc323874bd4..5b56e5895dc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-pkgbase = nocache-git
+# Generated by mksrcinfo v8
+# Tue May 17 17:17:06 UTC 2016
+pkgbase = nocache
pkgdesc = minimize caching effects
- pkgver = 100.a56cbb4
+ pkgver = 1.0
pkgrel = 1
url = https://github.com/Feh/nocache
arch = i686
arch = x86_64
license = FreeBSD License
- makedepends = git
- makedepends = gcc
- makedepends = make
- conflicts = nocache
- source = nocache-git::git://github.com/Feh/nocache.git
- sha1sums = SKIP
+ source = git+https://github.com/Feh/nocache.git#tag=v1.0
+ sha256sums = SKIP
-pkgname = nocache-git
+pkgname = nocache
diff --git a/PKGBUILD b/PKGBUILD
index 72cbe20bb474..2c69973895c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-# Maintainer: goll <adrian.goll+aur[at]gmail>
+# Maintainer: <grawity@gmail.com>
+# Contributor: goll <adrian.goll+aur[at]gmail>
-pkgname=nocache-git
-pkgver=100.a56cbb4
+pkgname=nocache
+pkgver=1.0
pkgrel=1
pkgdesc="minimize caching effects"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="https://github.com/Feh/nocache"
license=('FreeBSD License')
-makedepends=('git' 'gcc' 'make')
-conflicts=('nocache')
-source=("$pkgname"::'git://github.com/Feh/nocache.git')
-sha1sums=('SKIP')
+source=("git+https://github.com/Feh/nocache.git#tag=v1.0")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe | sed "s/^v//; s/-/.r/; s/-/./"
}
build() {
- cd "${srcdir}/${pkgname}"
- make
+ cd "$pkgname"
+ make
}
package() {
- cd "${srcdir}/${pkgname}"
- make DESTDIR="${pkgdir}" install PREFIX=/usr
+ cd "$pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}
+
+# vim: ts=2:sw=2:et: