summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannick Hemelhof2018-06-26 14:17:43 +0200
committerJannick Hemelhof2018-06-26 14:17:43 +0200
commit293b35ade486327725c22d44521bf3fc6763f5b9 (patch)
tree880454da523be686ded932c72a42c0bb113aaa11
parenta7f3e284ae7694ed531328fac4f1d4a8bb849247 (diff)
downloadaur-293b35ade486327725c22d44521bf3fc6763f5b9.tar.gz
Fix package building
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90bf730edcf2..f84e38f0e6b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = node-prune
pkgdesc = Remove unnecessary files from node_modules
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tj/node-prune
arch = x86_64
license = MIT
- makedepends = go
- source = node-prune-1.0.1.tar.gz::https://github.com/tj/node-prune/archive/v1.0.1.tar.gz
- sha512sums = 35896924bd1640c2500fdf7c36fa31479d44772930ef8a21b0e707c663cc467d71c41f717e169aed6b812791588e2852020acfe0f657cd6eff890c64f8fa4dc8
+ source = node-prune-1.0.1.tar.gz::https://github.com/tj/node-prune/releases/download/v1.0.1/node-prune_1.0.1_linux_amd64.tar.gz
+ sha512sums = db14ed6605a5c300064fe3c1339b8370dd430d3367169e8dba12f75a0b4e309ec4b0dff8abe7eeec3ae1abc1f58c2e97613ae3cf9394736ee04b4a7147cc5ffd
pkgname = node-prune
diff --git a/PKGBUILD b/PKGBUILD
index 2806d10bf5ef..8939b4def1f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,19 @@
pkgname=node-prune
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Remove unnecessary files from node_modules"
arch=('x86_64')
url="https://github.com/tj/node-prune"
license=('MIT')
-makedepends=('go')
source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/tj/node-prune/archive/v1.0.1.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/tj/node-prune/releases/download/v1.0.1/node-prune_1.0.1_linux_amd64.tar.gz"
)
-sha512sums=('35896924bd1640c2500fdf7c36fa31479d44772930ef8a21b0e707c663cc467d71c41f717e169aed6b812791588e2852020acfe0f657cd6eff890c64f8fa4dc8')
-
-build() {
- cd "${pkgname}-${pkgver}"
-
- go build cmd/"${pkgname}"/main.go
-}
+sha512sums=('db14ed6605a5c300064fe3c1339b8370dd430d3367169e8dba12f75a0b4e309ec4b0dff8abe7eeec3ae1abc1f58c2e97613ae3cf9394736ee04b4a7147cc5ffd')
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${srcdir}"
- install -Dm755 main "$pkgdir/usr/bin/${pkgname}"
+ install -Dm755 ${pkgname} "$pkgdir/usr/bin/${pkgname}"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file