summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-07 14:53:45 +0300
committerCaleb Maclennan2020-03-07 14:53:45 +0300
commit4b6acd36763345c271267a098ada32b7ee8977d9 (patch)
treecfcb71d32109175362eb33c5427831add6f900f8
parentbc56532ac8091f4b5e2ac42d2a4ccf3940eb33f2 (diff)
downloadaur-4b6acd36763345c271267a098ada32b7ee8977d9.tar.gz
Minor package cleanup
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57587cd28314..6a9d779c6f8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-_npmname=node-addon-api
-pkgname="${_npmname/-/js-}"
+pkgname=nodejs-addon-api
+_npmname=${pkgname/js}
pkgver=2.0.0
pkgrel=1
pkgdesc='Node.js API (N-API)'
@@ -15,7 +15,7 @@ sha256sums=('1a84bbf44b12660d2a241ee30338de6fd8be41992efa4bc8ceef42c763ce6088')
noextract=("${source[@]##*/}")
package() {
- npm install -g --user root --cache "$srcdir/npm-cache" --prefix "$pkgdir/usr" "${source[@]##*/}"
+ npm install -g --user root --cache "$srcdir/npm-cache" --no-audit --no-fund --prefix "$pkgdir/usr" "${source[@]##*/}"
find "$pkgdir"/usr -type d -exec chmod 755 {} +
find "$pkgdir" -type f -name package.json \
-execdir sh -c "jq '. |= with_entries(select(.key | test(\"_.+\") | not))' {} | sponge {}" \;