summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjolupa2018-11-28 03:16:35 +0100
committerjolupa2018-11-28 03:16:35 +0100
commit9b51e3856019515c19bb5503fa91cfa36e1d6ae0 (patch)
treefce3bb5a1b64e2d90c3c4d34706f4edb59e2e4cc
downloadaur-9b51e3856019515c19bb5503fa91cfa36e1d6ae0.tar.gz
Primera versió nou nom
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD34
-rw-r--r--nodejs-afterwriting-1.11.0-1-any.pkg.tar.xz.sigbin0 -> 310 bytes
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca172cd78aa6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nodejs-afterwriting
+ pkgdesc = Afterwriting CLI is a command line tool that lets you generate PDF from your fountain script using node.js.
+ pkgver = 1.11.0
+ pkgrel = 1
+ url = https://github.com/ifrost/afterwriting-labs/blob/master/docs/clients.md
+ arch = any
+ license = MIT
+ makedepends = npm
+ makedepends = jq
+ depends = nodejs
+ noextract = afterwriting-1.11.0.tgz
+ source = https://registry.npmjs.org/afterwriting/-/afterwriting-1.11.0.tgz
+ source = LICENSE
+ sha256sums = 5f4d4d20c5029591a06c5f4636b4c5eb165ca1a852b778596519d2a16d12d5e7
+ sha256sums = abb42abaef9d2198f1d38b5b40c3c8accec9a8e8bdea7b0994270d75a3beb931
+
+pkgname = nodejs-afterwriting
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b51f48c63c40
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright (c) 2015-2018 Piotr Jamróz
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5ae309a40c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: jolupa <jlpavon@me.com>
+pkgname=nodejs-afterwriting
+_pkgname=afterwriting
+pkgver=1.11.0
+pkgrel=1
+pkgdesc="Afterwriting CLI is a command line tool that lets you generate PDF from your fountain script using node.js."
+arch=('any')
+url="https://github.com/ifrost/afterwriting-labs/blob/master/docs/clients.md"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm' 'jq')
+source=("https://registry.npmjs.org/afterwriting/-/$_pkgname-$pkgver.tgz"
+ "LICENSE")
+sha256sums=("5f4d4d20c5029591a06c5f4636b4c5eb165ca1a852b778596519d2a16d12d5e7"
+ "abb42abaef9d2198f1d38b5b40c3c8accec9a8e8bdea7b0994270d75a3beb931")
+noextract=("$_pkgname-$pkgver.tgz")
+
+package() {
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$_pkgname-$pkgver.tgz"
+ find "$pkgdir/usr" -type d -exec chmod 755 {} +
+
+ # Remove references to $pkgdir
+ find "$pkgdir" -type f -name package.json -print0 | xargs -0 sed -i "/_where/d"
+
+ # Remove references to $srcdir
+ local tmppackage="$(mktemp)"
+ local pkgjson="$pkgdir/usr/lib/node_modules/$_pkgname/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
+ mv "$tmppackage" "$pkgjson"
+ chmod 644 "$pkgjson"
+
+ # Install license since the package doesn't include it
+ install -Dm 644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/nodejs-afterwriting-1.11.0-1-any.pkg.tar.xz.sig b/nodejs-afterwriting-1.11.0-1-any.pkg.tar.xz.sig
new file mode 100644
index 000000000000..8ece2fcc785d
--- /dev/null
+++ b/nodejs-afterwriting-1.11.0-1-any.pkg.tar.xz.sig
Binary files differ