summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:21:23 +0900
committerDaichi Shinozaki2015-06-09 18:21:23 +0900
commit7ec8c37272a64f9f76166f53416a401649988d27 (patch)
tree1b7bdbc3c450cc3346a29279f8d079f2f2220e4e
downloadaur-7ec8c37272a64f9f76166f53416a401649988d27.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--Makefile.patch13
-rw-r--r--PKGBUILD43
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97b93fbc50a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nodejs-async
+ pkgdesc = Higher-order functions and common patterns for asynchronous code
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/caolan/async
+ arch = any
+ license = MIT
+ checkdepends = nodejs-nodeunit
+ makedepends = nodejs
+ makedepends = nodejs-uglify-js
+ provides = nodejs-async
+ source = https://github.com/caolan/async/archive/0.9.2.tar.gz
+ source = Makefile.patch
+ md5sums = 13c1cfbc4fc6b99b0d4e94cd1d453e16
+ md5sums = d514b5c61b237cbe1b225d15389eb110
+
+pkgname = nodejs-async
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..629049f4c080
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile.orig 2014-12-19 05:55:26.000000000 +0900
++++ Makefile 2015-02-01 16:54:37.438964118 +0900
+@@ -1,8 +1,8 @@
+ PACKAGE = asyncjs
+ NODEJS = $(if $(shell test -f /usr/bin/nodejs && echo "true"),nodejs,node)
+ CWD := $(shell pwd)
+-NODEUNIT = $(CWD)/node_modules/nodeunit/bin/nodeunit
+-UGLIFY = $(CWD)/node_modules/uglify-js/bin/uglifyjs
++NODEUNIT = /usr/bin/nodeunit
++UGLIFY = /usr/bin/uglifyjs
+ NODELINT = $(CWD)/node_modules/nodelint/nodelint
+
+ BUILDDIR = dist
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c6c5b3fc323
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=nodejs-async
+_npmname=async
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="Higher-order functions and common patterns for asynchronous code"
+arch=('any')
+makedepends=('nodejs' 'nodejs-uglify-js')
+checkdepends=('nodejs-nodeunit')
+url="https://github.com/caolan/async"
+license=('MIT')
+provides=('nodejs-async')
+source=("https://github.com/caolan/$_npmname/archive/$pkgver.tar.gz"
+ 'Makefile.patch')
+md5sums=('13c1cfbc4fc6b99b0d4e94cd1d453e16'
+ 'd514b5c61b237cbe1b225d15389eb110')
+
+prepare() {
+ cd $srcdir/${pkgname#nodejs-}-$pkgver
+ patch -p0 -i $srcdir/Makefile.patch
+}
+
+build() {
+ cd $srcdir/${pkgname#nodejs-}-$pkgver
+ make build
+}
+
+check() {
+ cd $srcdir/${pkgname#nodejs-}-$pkgver
+ make test
+}
+
+package() {
+ mkdir -m755 -p $pkgdir/usr/lib/node_modules/async/lib
+ cd $srcdir/${pkgname#nodejs-}-$pkgver
+ install -m644 -t $pkgdir/usr/lib/node_modules/async README.md {bower,component,package}.json
+ install -m644 -t $pkgdir/usr/lib/node_modules/async/lib lib/async.js dist/async.min.js
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+