summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 13:58:51 -0600
committerJohn D Jones III2015-06-16 13:58:51 -0600
commit415431fac82882a9dbaf6f3e5421cbaa4df3c1f1 (patch)
treedf9acff25218a58e5b7979ca00628459010ab553
downloadaur-nodejs-aws-lib.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1210178d2bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nodejs-aws-lib
+ pkgdesc = Extensible Node.js library for the Amazon Web Services API
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/livelycode/aws-lib
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = aws-lib-0.3.0.tgz
+ source = http://registry.npmjs.org/aws-lib/-/aws-lib-0.3.0.tgz
+ sha1sums = 213c04bb357a7c6764bc099f58cb6336a957d198
+
+pkgname = nodejs-aws-lib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf3f39990fce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Author: Filirom1 <filirom1@gmail.com>
+# Maintainer: filirom1 <filirom1@gmail.com>
+_npmname=aws-lib
+_npmver=0.3.0
+pkgname=nodejs-aws-lib # All lowercase
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Extensible Node.js library for the Amazon Web Services API"
+arch=(any)
+url="https://github.com/livelycode/aws-lib"
+license=(MIT)
+depends=('nodejs' 'npm')
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=("213c04bb357a7c6764bc099f58cb6336a957d198")
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: