summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamie Magee2018-07-13 11:45:00 +0200
committerJamie Magee2018-07-13 11:45:00 +0200
commitd6d6fa318892b5d595b83089bf91eae52d81c544 (patch)
treee94643e60827920b7c0b00934e1c97da1ce9db05
downloadaur-d6d6fa318892b5d595b83089bf91eae52d81c544.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66c7a5bf1c9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nodejs-azurite
+ pkgdesc = A lightweight server clone of Azure Storage that simulates most of the commands supported by it with minimal dependencies
+ pkgver = 2.6.5
+ pkgrel = 1
+ url = https://github.com/azure/azurite
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = azurite-2.6.5.tgz
+ source = https://registry.npmjs.org/azurite/-/azurite-2.6.5.tgz
+ sha256sums = bd23d804d5b72719089d0d3f37e0041e3e8281ecef1a9a0613797374ee6ee9db
+
+pkgname = nodejs-azurite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89f485760fc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jamie Magee <jamie DOT magee AT gmail DOT com>
+_npmname=azurite
+_npmver=2.6.5
+pkgname=nodejs-azurite
+pkgver=2.6.5
+pkgrel=1
+pkgdesc="A lightweight server clone of Azure Storage that simulates most of the commands supported by it with minimal dependencies"
+arch=(any)
+url="https://github.com/azure/azurite"
+license=(MIT)
+depends=('nodejs' 'npm')
+optdepends=()
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha256sums=('bd23d804d5b72719089d0d3f37e0041e3e8281ecef1a9a0613797374ee6ee9db')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+}