summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2018-02-28 07:43:26 -0500
committerMario Finelli2018-02-28 07:43:26 -0500
commitc81a16ec523351ee44ffe2a83935ff4871b46f14 (patch)
tree03f3428499216b3ae6cc6818a64331beffe80fa8
parente60d5f17b6e67c290a86debee1a32e4bbd864da7 (diff)
downloadaur-c81a16ec523351ee44ffe2a83935ff4871b46f14.tar.gz
Bump to 4.1.9
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff6b1aae279..e42a2aeb4c81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = nodejs-clean-css
pkgdesc = A fast, efficient, and well tested CSS minifier for node.js.
- pkgver = 3.3.9
+ pkgver = 4.1.9
pkgrel = 1
url = https://github.com/jakubpawlowicz/clean-css
arch = any
license = MIT
+ makedepends = npm
depends = nodejs
- depends = npm
- noextract = clean-css-3.3.9.tgz
- source = https://registry.npmjs.org/clean-css/-/clean-css-3.3.9.tgz
- sha256sums = d0351fd10618317d2117cce9d1e1dab7600426ed6f163b45039f0ad592f3588f
+ noextract = clean-css-4.1.9.tgz
+ source = https://registry.npmjs.org/clean-css/-/clean-css-4.1.9.tgz
+ sha256sums = a474469c4af681b798f5e9a6e97c1309a3124ad333e4e6f562ab8b3f8f19e04d
pkgname = nodejs-clean-css
diff --git a/PKGBUILD b/PKGBUILD
index 480071975541..77ab7c177f6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
-# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Maintainer: Mario Finelli <mario at finel dot li>
_npmname=clean-css
pkgname=nodejs-$_npmname
-pkgver=3.3.9
+pkgver=4.1.9
pkgrel=1
pkgdesc="A fast, efficient, and well tested CSS minifier for node.js."
arch=('any')
url="https://github.com/jakubpawlowicz/clean-css"
license=('MIT')
-depends=('nodejs' 'npm')
+depends=('nodejs')
+makedepends=('npm')
source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
noextract=($_npmname-$pkgver.tgz)
-sha256sums=('d0351fd10618317d2117cce9d1e1dab7600426ed6f163b45039f0ad592f3588f')
+sha256sums=('a474469c4af681b798f5e9a6e97c1309a3124ad333e4e6f562ab8b3f8f19e04d')
package() {
- cd "$srcdir"
- local _npmdir="$pkgdir/usr/lib/node_modules/"
- mkdir -p "$_npmdir"
- cd "$_npmdir"
- npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ npm install \
+ --user root --global \
+ --prefix "$pkgdir/usr" \
+ "$srcdir"/$_npmname-$pkgver.tgz
+
+ rm -r "$pkgdir"/usr/etc
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+
+ install -Dm0644 "$pkgdir/usr/lib/node_modules/$_npmname/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}