summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruzerus2018-01-08 23:01:02 +0100
committeruzerus2018-01-08 23:01:02 +0100
commitcc8ab1d0b72e9728131f28e0a34597a476f3f4f1 (patch)
treeb32123cf1a88c4e0f6057c3f170df148a73ae9bc
parentc0091ee1b6d0429cb5dc7085c8e9c6bb71a94836 (diff)
downloadaur-cc8ab1d0b72e9728131f28e0a34597a476f3f4f1.tar.gz
fully fixed and working
-rw-r--r--.SRCINFO3
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD6
3 files changed, 26 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e38201f4285..9fc70533a25c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nodejs-coffeelint
pkgdesc = Style checker for CoffeeScript
pkgver = 2.0.6
- pkgrel = 3
+ pkgrel = 4
url = http://www.coffeelint.org/
arch = any
license = MIT
@@ -9,6 +9,7 @@ pkgbase = nodejs-coffeelint
depends = nodejs
noextract = coffeelint-2.0.6.tar.gz
source = coffeelint-2.0.6.tar.gz::https://github.com/clutchski/coffeelint/archive/v2.0.6.tar.gz
+ source = LICENSE
md5sums = f5ff8853b9a53e5facab76d8420c5548
pkgname = nodejs-coffeelint
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..65b8dec4aa63
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+CoffeeLint
+Copyright (c) 2011 Matthew Perpick
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 33438afab119..2337a46921f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=nodejs-coffeelint
_pkgname=coffeelint
pkgver=2.0.6
-pkgrel=3
+pkgrel=4
pkgdesc="Style checker for CoffeeScript"
arch=(any)
url="http://www.coffeelint.org/"
@@ -13,7 +13,8 @@ license=('MIT')
depends=('nodejs')
makedepends=('npm')
optdepends=()
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/clutchski/coffeelint/archive/v2.0.6.tar.gz")
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/clutchski/coffeelint/archive/v2.0.6.tar.gz"
+"LICENSE")
noextract=($_pkgname-$pkgver.tar.gz)
package() {
@@ -27,6 +28,7 @@ package() {
find "$pkgdir"/usr -type d -exec chmod 755 '{}' + #fix bug https://bugs.archlinux.org/task/56962
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}
md5sums=('f5ff8853b9a53e5facab76d8420c5548')