summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2018-09-12 15:19:31 +0200
committerLukas Grossar2018-09-12 15:19:31 +0200
commit2cc101ca279df2c4a429dca5d236ec9e786131aa (patch)
tree4f5fb3693682a7bde0b93b5617917527ac4780a2
downloadaur-2cc101ca279df2c4a429dca5d236ec9e786131aa.tar.gz
initial commit v2.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..746670ff4bd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nodejs-cz-conventional-changelog
+ pkgdesc = Commitizen plugin for conventional changelogs commit messages
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/commitizen/cz-conventional-changelog
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ depends = nodejs-commitizen
+ noextract = cz-conventional-changelog-2.1.0.tgz
+ source = http://registry.npmjs.org/cz-conventional-changelog/-/cz-conventional-changelog-2.1.0.tgz
+ sha512sums = 4cc8e44abbe3bb97cf415f87a3c4c88a80205e4972f21def27fb7189ccc9ae551a2e980c180eacb27c2ab8b316ccd659c82b092b9af890f830768842e1400699
+
+pkgname = nodejs-cz-conventional-changelog
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d692c13bbbcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Author: Lukas Grossar <lukas.grossar@gmail.com
+# Maintainer: Lukas Grossar <lukas.grossar@gmail.com
+_npmname=cz-conventional-changelog
+_npmver=2.1.0
+pkgname=nodejs-cz-conventional-changelog
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Commitizen plugin for conventional changelogs commit messages"
+arch=(any)
+url="https://github.com/commitizen/cz-conventional-changelog"
+license=(MIT)
+depends=('nodejs' 'npm' 'nodejs-commitizen')
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha512sums=('4cc8e44abbe3bb97cf415f87a3c4c88a80205e4972f21def27fb7189ccc9ae551a2e980c180eacb27c2ab8b316ccd659c82b092b9af890f830768842e1400699')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et:<Paste>