summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpat-s2018-03-09 23:07:14 +0100
committerpat-s2018-03-09 23:07:14 +0100
commitd65a771033cf35127d09c93be13c92272aa0311e (patch)
tree556db1db5f8f1e6d9cb3e83216ebeb164f255f6a
downloadaur-d65a771033cf35127d09c93be13c92272aa0311e.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76e9f847c5fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nodejs-decktape
+ pkgdesc = PDF exporter for HTML presentation frameworks
+ pkgver = 2.8.0
+ pkgrel = 1
+ url = https://github.com/astefanutti/decktape
+ arch = any
+ license = MIT
+ depends = npm
+ depends = nodejs
+ source = decktape-2.8.0.tar.gz::https://github.com/astefanutti/decktape/archive/v2.8.0.tar.gz
+ md5sums = 6d833e002dfcbffe5d0efdaefb9170f5
+
+pkgname = nodejs-decktape
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48afbb0cfc52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Patrick Schratz <patrick.schratz@gmail.com>
+# Adapted from nodejs-mkdirp
+
+pkgname=nodejs-decktape
+_npmname=decktape
+pkgver=2.8.0
+pkgrel=1
+pkgdesc='PDF exporter for HTML presentation frameworks'
+arch=('any')
+url='https://github.com/astefanutti/decktape'
+license=('MIT')
+depends=('npm' 'nodejs')
+source=("${_npmname}-${pkgver}.tar.gz::https://github.com/astefanutti/"${_npmname}"/archive/v"${pkgver}".tar.gz")
+
+package() {
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ rmdir "${pkgdir}/usr/etc"
+}
+md5sums=('6d833e002dfcbffe5d0efdaefb9170f5')