aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2020-08-20 22:40:13 +0300
committerDāvis2020-08-20 22:40:13 +0300
commitec26e69928b796df6d46fed570c6a8da0faea75f (patch)
tree39df41688da3cbfe80bb6bc361998238a84036fa
downloadaur-ec26e69928b796df6d46fed570c6a8da0faea75f.tar.gz
First release
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
-rw-r--r--README.md4
-rw-r--r--UNLICENSE24
5 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e17db53e17f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = nodejs-epicgames-client
+ pkgdesc = Unofficial EpicGames Client for Node.js
+ pkgver = 2.0.25
+ pkgrel = 1
+ url = https://github.com/SzymonLisowiec/node-epicgames-client
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+
+pkgname = nodejs-epicgames-client
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f9b191a67a9b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar*
+/*.zip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dc9d5186045
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_package=epicgames-client
+pkgname="nodejs-$_package"
+pkgver="2.0.25"
+pkgrel=1
+pkgdesc="Unofficial EpicGames Client for Node.js"
+arch=("any")
+url="https://github.com/SzymonLisowiec/node-epicgames-client"
+license=("MIT")
+depends=("nodejs")
+makedepends=("npm")
+
+pkgver() {
+ npm info --json "$_package" | jq ".version"
+}
+
+package() {
+ npm install -g --user root --cache "$srcdir/npm-cache" --prefix "$pkgdir/usr" "$_package"
+
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
+ find "$pkgdir/usr" -type d -exec chmod 755 {} +
+
+ find "$pkgdir" -name package.json -print0 | xargs -r0 sed -i "s|$pkgdir||"
+ find "$pkgdir" -name package.json -print0 | xargs -r0 sed -i "s|$srcdir|/usr/lib/node_modules/$_package|"
+
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..3b1ad908090c
--- /dev/null
+++ b/README.md
@@ -0,0 +1,4 @@
+# Epic Games client for Node.js
+
+See https://github.com/SzymonLisowiec/node-epicgames-client
+
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>