summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2021-06-20 02:04:48 +0000
committerGitHub Action2021-06-20 02:04:48 +0000
commita09eaaf923f26e5b397286d2ed13a6c73e038c4e (patch)
tree870c8ae1fcc750105a39b9958b7dc358cdc4ed46
parentecdb2bbefab44eb1aec06b660ceb39aef9e5ee26 (diff)
downloadaur-a09eaaf923f26e5b397286d2ed13a6c73e038c4e.tar.gz
Update from GitHub Actions: nodejs-express: update to 4.17.1-1
https://github.com/ouuan/AUR-packages/actions/runs/953566235
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 20 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2a9a577e254..112942cca2cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = nodejs-express
- pkgdesc = Fast, unopinionated, minimalist web framework.
- pkgver = 4.16.3
+ pkgdesc = Fast, unopinionated, minimalist web framework for node.
+ pkgver = 4.17.1
pkgrel = 1
- url = https://expressjs.com
+ url = https://github.com/expressjs/express
arch = any
license = MIT
makedepends = npm
depends = nodejs
- noextract = express-4.16.3.tgz
- source = https://registry.npmjs.org/express/-/express-4.16.3.tgz
- sha256sums = 7e6e24c704d81f81b24f19e6faf1613b3eca752363b755e61debe02ef77a0ca8
+ noextract = express-4.17.1.tgz
+ source = https://registry.npmjs.org/express/-/express-4.17.1.tgz
+ sha256sums = 2600b551c4e3f56d1bd5e28505d4ecfe3e73e58cc3a0ad5be08c0bf395aa02a9
pkgname = nodejs-express
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f71c635dafda..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 000211edca60..7617774665cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer: Mario Finelli <mario at finel dot li>
+# Maintainer: Yufan You <ouuansteve at gmail>
+# Contributor: Mario Finelli <mario at finel dot li>
# Contributor: Mark Pustjens <pustjens at dds dot nl>
_npmname=express
-pkgname=nodejs-$_npmname
-pkgver=4.16.3
+pkgname=nodejs-express
+pkgver=4.17.1
pkgrel=1
-pkgdesc="Fast, unopinionated, minimalist web framework."
+pkgdesc="Fast, unopinionated, minimalist web framework for node."
arch=('any')
-url="https://expressjs.com"
+url="https://github.com/expressjs/express"
license=('MIT')
depends=('nodejs')
makedepends=('npm')
source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
noextract=($_npmname-$pkgver.tgz)
-sha256sums=('7e6e24c704d81f81b24f19e6faf1613b3eca752363b755e61debe02ef77a0ca8')
+sha256sums=('2600b551c4e3f56d1bd5e28505d4ecfe3e73e58cc3a0ad5be08c0bf395aa02a9')
package() {
- npm install \
- --user root --global \
- --prefix "$pkgdir/usr" \
- "$srcdir"/$_npmname-$pkgver.tgz
-
- find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
-
- install -Dm0644 "$pkgdir/usr/lib/node_modules/$_npmname/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$pkgver"
+ install -Dm644 "$_npmdir/$_npmname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ chown -R root:root "${pkgdir}"
}