summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Edwards2018-08-08 21:41:42 +0100
committerBen Edwards2018-08-08 21:41:42 +0100
commit8aaba07121e1616a4c6504383676c275c374e801 (patch)
treefeed809e73c175951b14da7e75f6a15e13385155
downloadaur-8aaba07121e1616a4c6504383676c275c374e801.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..976508a1c0fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nodejs-fauna-shell
+ pkgdesc = faunadb access via the cli
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/fauna/fauna-shell
+ arch = any
+ makedepends = npm
+ depends = nodejs
+ noextract = fauna-shell-0.3.0.tgz
+ source = https://registry.npmjs.org/fauna-shell/_/fauna-shell-0.3.0.tgz
+ sha256sums = e587255300cfd8e8be5afa5d9497bdb612eeeca5e165d65bd05fbd2e041ec840
+
+pkgname = nodejs-fauna-shell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..623f021e536b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=nodejs-fauna-shell
+_pkgname=${pkgname#nodejs-}
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="faunadb access via the cli"
+arch=(any)
+url="https://github.com/fauna/fauna-shell"
+licence=(MPL2)
+depends=(nodejs)
+makedepends=(npm)
+source=("https://registry.npmjs.org/$_pkgname/_/$_pkgname-$pkgver.tgz")
+sha256sums=('e587255300cfd8e8be5afa5d9497bdb612eeeca5e165d65bd05fbd2e041ec840')
+noextract=("$_pkgname-$pkgver.tgz")
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/"$_pkgname-$pkgver.tgz"
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+}