summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Mousavi2020-02-25 23:45:22 +0330
committerAli Mousavi2020-02-25 23:45:22 +0330
commitaf0f9b0b2deafa7f955994c59d45604f199a748d (patch)
tree955ffb6556149fc6aaf021e69c51777e78375820
parent08f7fbe855bd4f270093f24b6d28d300f194ecad (diff)
downloadaur-af0f9b0b2deafa7f955994c59d45604f199a748d.tar.gz
update to version 2.9.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dfab4e517b4..d9fe8f974eac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nodejs-gatsby-cli
pkgdesc = The Gatsby command line interface
- pkgver = 2.8.13
+ pkgver = 2.9.0
pkgrel = 1
url = https://github.com/gatsbyjs/gatsby/tree/master/packages/gatsby-cli
arch = any
@@ -8,9 +8,9 @@ pkgbase = nodejs-gatsby-cli
makedepends = npm
makedepends = jq
depends = nodejs
- noextract = gatsby-cli-2.8.13.tgz
- source = https://registry.npmjs.org/gatsby-cli/-/gatsby-cli-2.8.13.tgz
- md5sums = 02e236e6ac5d28e640005b5ae90ae5af
+ noextract = gatsby-cli-2.9.0.tgz
+ source = https://registry.npmjs.org/gatsby-cli/-/gatsby-cli-2.9.0.tgz
+ md5sums = 5693b5c7d81bdf8d3ebc2dff901ffedf
pkgname = nodejs-gatsby-cli
diff --git a/PKGBUILD b/PKGBUILD
index 875870c1c177..2087ca6e6668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ali Mousavi <ali.mousavi@gmail.com>
_npmname=gatsby-cli
-pkgname=nodejs-$_npmname
-pkgver=2.8.13
+pkgname=nodejs-${_npmname}
+pkgver=2.9.0
pkgrel=1
pkgdesc="The Gatsby command line interface"
arch=(any)
@@ -9,27 +9,27 @@ url="https://github.com/gatsbyjs/gatsby/tree/master/packages/gatsby-cli"
license=('MIT')
depends=('nodejs')
makedepends=('npm' 'jq')
-source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+source=("https://registry.npmjs.org/${_npmname}/-/${_npmname}-${pkgver}.tgz")
noextract=($_npmname-$pkgver.tgz)
-md5sums=('02e236e6ac5d28e640005b5ae90ae5af')
+md5sums=('5693b5c7d81bdf8d3ebc2dff901ffedf')
package() {
- npm install -g --cache $srcdir/npm-cache --user root --prefix $pkgdir/usr $srcdir/$_npmname-$pkgver.tgz
- find "$pkgdir"/usr -type d -exec chmod 755 {} +
- chown -R root:root "$pkgdir"
+ npm install -g --cache "${srcdir}/npm-cache" --user root --prefix "${pkgdir}/usr" "${srcdir}/${_npmname}-${pkgver}.tgz"
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+ chown -R root:root "${pkgdir}"
# Remove references to $pkgdir
- find "$pkgdir" -type f -name package.json -print0 | xargs -0 sed -i "/_where/d"
+ find "${pkgdir}" -type f -name package.json -print0 | xargs -0 sed -i "/_where/d"
# Remove references to $srcdir
local tmppackage="$(mktemp)"
- local pkgjson="$pkgdir/usr/lib/node_modules/$_npmname/package.json"
- jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
- mv "$tmppackage" "$pkgjson"
- chmod 644 "$pkgjson"
+ local pkgjson="${pkgdir}/usr/lib/node_modules/${_npmname}/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "${pkgjson}" > "${tmppackage}"
+ mv "${tmppackage}" "${pkgjson}"
+ chmod 644 "${pkgjson}"
# Install license file
- mkdir -p "$pkgdir/usr/share/licenses/$pkgdir"
- mv "$pkgdir/usr/lib/node_modules/$_npmname/LICENSE" "$pkgdir/usr/share/licenses/$pkgdir/LICENSE"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgdir}"
+ mv "${pkgdir}/usr/lib/node_modules/${_npmname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgdir}/LICENSE"
}