summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuologic2020-11-17 15:31:25 +0100
committerDuologic2020-11-17 15:31:25 +0100
commitecac020456866d1245e78d55af08b58360d12d7f (patch)
tree4b59dc3433ebd27346b3f0f8ec3afb85c352ef8d
downloadaur-ecac020456866d1245e78d55af08b58360d12d7f.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3d718e3f70a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nodejs-git-file-history
+ pkgdesc = Quickly browse the history of a file from any git repository.
+ pkgver = 1.0.1
+ pkgrel = 0
+ url = https://github.com/pomber/git-history/tree/master/cli
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = git-file-history-1.0.1.tgz
+ source = https://registry.npmjs.org/git-file-history/-/git-file-history-1.0.1.tgz
+ sha256sums = 0a2705cfd57021c715b3bef53a2bfbc564923afa739374802a54d94c75c85592
+
+pkgname = nodejs-git-file-history
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f737038e7e03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Duologic <jeroen@simplistic.be>
+
+_npmname=git-file-history
+pkgname=nodejs-"$_npmname"
+pkgver=1.0.1
+pkgrel=0
+pkgdesc='Quickly browse the history of a file from any git repository.'
+arch=('any')
+url="https://github.com/pomber/git-history/tree/master/cli"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+sha256sums=('0a2705cfd57021c715b3bef53a2bfbc564923afa739374802a54d94c75c85592')
+noextract=("${source[@]##*/}")
+
+package() {
+ npm install -g --user root --cache "$srcdir/npm-cache" --prefix "$pkgdir/usr" "${source[@]##*/}"
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+}