summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHrvoje Juric2021-11-03 19:50:56 +0100
committerHrvoje Juric2021-11-03 19:50:56 +0100
commite844df8e9125c3645a3f1256b5860c4a9b6eadbf (patch)
tree8acb29763cfa195190ca9334174db918935f3436
downloadaur-e844df8e9125c3645a3f1256b5860c4a9b6eadbf.tar.gz
pkgrel 1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cf850150797
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nodejs-graphql-cli
+ pkgdesc = Repo and documentation at: https://github.com/Urigo/graphql-cli
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://github.com/Urigo/graphql-cli
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = graphql-cli-4.1.0.tgz
+ source = https://registry.npmjs.org/graphql-cli/-/graphql-cli-4.1.0.tgz
+ sha256sums = c52d62ac108d4a3f711dbead0939bd02e3e2d0c82f8480fd76fc28f285602f5c
+
+pkgname = nodejs-graphql-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0e970acfed5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hrvoje Juric <5b0bae33-0d7b-4297-b3a5-f6294b4bfd39@anonaddy.me>
+_npmname=graphql-cli
+_npmver=4.1.0
+pkgname="nodejs-${_npmname}"
+pkgver="${_npmver}"
+pkgrel=1
+pkgdesc="Repo and documentation at: https://github.com/Urigo/graphql-cli"
+arch=('any')
+url="https://github.com/Urigo/graphql-cli"
+license=('MIT')
+depends=('nodejs' 'npm')
+source=("https://registry.npmjs.org/${_npmname}/-/${_npmname}-${_npmver}.tgz")
+noextract=("${_npmname}-${_npmver}.tgz")
+sha256sums=('c52d62ac108d4a3f711dbead0939bd02e3e2d0c82f8480fd76fc28f285602f5c')
+
+package() {
+ cd "${srcdir}"
+ local _npmdir="${pkgdir}/usr/lib/node_modules/"
+ mkdir -p "${_npmdir}"
+ cd "${_npmdir}"
+ npm install --user root -g --prefix "${pkgdir}/usr" "${_npmname}@${_npmver}"
+}