summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtech Kral2015-09-29 18:09:02 +0200
committerVojtech Kral2015-09-29 18:10:21 +0200
commit9336fb5f978a9709413f16fb6616f13e2f9f4805 (patch)
treef42dd4758d209ec736f7e2860e4e98b403435e14
downloadaur-9336fb5f978a9709413f16fb6616f13e2f9f4805.tar.gz
Initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d4fe5d415ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nodejs-handlebars
+ pkgdesc = Handlebars provides the power necessary to let you build semantic templates effectively with no frustration.
+ pkgver = 4.0.2
+ pkgrel = 1
+ url = http://handlebarsjs.com/
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = handlebars-4.0.2.tgz
+ source = http://registry.npmjs.org/handlebars/-/handlebars-4.0.2.tgz
+ sha256sums = 09807745ef628ab8046c2cbce9f0e1c42e9b31e9f631e7bcc832a972a36182c2
+
+pkgname = nodejs-handlebars
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e5185529255
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Vojtech Kral <vojtech_kral^hk>
+
+_npmname=handlebars
+pkgname="nodejs-${_npmname}"
+pkgver=4.0.2
+pkgrel=1
+pkgdesc='Handlebars provides the power necessary to let you build semantic templates effectively with no frustration.'
+arch=('any')
+url='http://handlebarsjs.com/'
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=("http://registry.npmjs.org/${_npmname}/-/${_npmname}-${pkgver}.tgz")
+noextract=("${_npmname}-${pkgver}.tgz")
+sha256sums=('09807745ef628ab8046c2cbce9f0e1c42e9b31e9f631e7bcc832a972a36182c2')
+
+package() {
+ local _npmdir="${pkgdir}/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install --user root -g --prefix "${pkgdir}/usr" "${_npmname}@${pkgver}"
+ rmdir "${pkgdir}/usr/etc"
+}