summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:22:03 +0900
committerDaichi Shinozaki2015-06-09 18:22:03 +0900
commit4b533b24582a2c79a36c852dc97ef6d7b1a298cc (patch)
tree34a05a5a4883fe2d00af55184e8c4f015be46b38
downloadaur-4b533b24582a2c79a36c852dc97ef6d7b1a298cc.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d132c81045c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nodejs-hubot
+ pkgdesc = A simple helpful robot for your Company
+ pkgver = 2.12.0
+ pkgrel = 1
+ url = https://github.com/github/hubot
+ arch = any
+ license = MIT
+ depends = nodejs
+ noextract = hubot-2.12.0.tgz
+ source = http://registry.npmjs.org/hubot/-/hubot-2.12.0.tgz
+ sha1sums = bf67686741740f41ba09a6a1d5b269ca66d5933d
+
+pkgname = nodejs-hubot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2427d31edcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=hubot
+_npmver=2.12.0
+pkgname=nodejs-hubot # All lowercase
+pkgver=2.12.0
+pkgrel=1
+pkgdesc="A simple helpful robot for your Company"
+arch=(any)
+url="https://github.com/github/hubot"
+license=(MIT)
+depends=('nodejs' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(bf67686741740f41ba09a6a1d5b269ca66d5933d)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file