summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Hague2015-10-08 20:47:48 +0100
committerMatthew Hague2015-10-08 20:47:48 +0100
commitaf6b223a2a8e707596f9a3a9ef0824665d7f4bec (patch)
tree73540282ce819f3e27fd318c9628a1f0fbee9913
parenta58212096a0df67ef077ec2e72cfa2d5fc32318a (diff)
downloadaur-af6b223a2a8e707596f9a3a9ef0824665d7f4bec.tar.gz
moved service file to systemd/user and removed _ from config location
-rw-r--r--PKGBUILD7
-rw-r--r--imapnotify@.service3
-rw-r--r--nodejs-imapnotify.install2
3 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f111b451f6bf..6fb1e3af51f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_npmname=imapnotify
pkgname=nodejs-imapnotify # All lowercase
pkgver=0.1.0
-pkgrel=4
+pkgrel=5
pkgdesc="Execute scripts on new messages using IDLE imap command"
arch=(any)
url="http://github.com/a-sk/node-imapnotify"
@@ -14,12 +14,13 @@ install=$pkgname.install
source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz "imapnotify@.service")
noextract=($_npmname-$pkgver.tgz)
sha1sums=(33be4a48d86b7aec069d4f7243bf66b980583e5b
- 789a2e923e337ec2cd8664d5191fcffb8e0ff402)
+ efa2e526c4ba592af7eb5060493d7fbc7d4340e7)
+
package() {
cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
cd $_npmdir
PYTHON=/usr/bin/python2 npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
- install -Dm644 "${srcdir}/imapnotify@.service" "${pkgdir}/usr/lib/systemd/system/imapnotify@.service"
+ install -Dm644 "${srcdir}/imapnotify@.service" "${pkgdir}/usr/lib/systemd/user/imapnotify@.service"
}
diff --git a/imapnotify@.service b/imapnotify@.service
index 5d14588babac..621815a2d7e0 100644
--- a/imapnotify@.service
+++ b/imapnotify@.service
@@ -3,9 +3,8 @@ Description=Execute scripts on new messages using IDLE imap command
After=network.target
[Service]
-User=username
Type=simple
-ExecStart=/usr/bin/imapnotify -c ~/.config/imap_inotify/%I.json
+ExecStart=/usr/bin/imapnotify -c ~/.config/imapnotify/%I.json
Restart=on-failure
RestartSec=20
diff --git a/nodejs-imapnotify.install b/nodejs-imapnotify.install
index 33b4715be95a..2a32afa20dc7 100644
--- a/nodejs-imapnotify.install
+++ b/nodejs-imapnotify.install
@@ -13,7 +13,7 @@ BLUE="${BOLD}$(tput setaf 4)"
YELLOW="${BOLD}$(tput setaf 3)"
post_install() {
- note "Copy /usr/lib/systemd/system/imapnotify@.service to /etc/systemd/system and replace User=username with your username"
+ note "To use with systemd, place a config file in ~/.config/imapnotify/<config>.json and use systemctl --user enable imapnotify@<config>"
}
post_upgrade() {